Bug 870070 - ovirt engine should require a version of vdsm-bootstrap containing interface-2
ovirt engine should require a version of vdsm-bootstrap containing interface-2
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.1 RC
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.2
Assigned To: Ohad Basan
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 10:11 EDT by Ohad Basan
Modified: 2014-10-30 18:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:46:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2012-10-25 10:11:06 EDT
Description of problem:
ovirt-engine is creating vdsm-bootstrap-2.tar based on wrong path of files.
should be interface-2.
if vdsm-boostrap<4.10.1  the vdsm-bootstrap-2.tar remains empty

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.install ovirt-engine stable
2.update ovirt-engine to latest nightly (vdsm-bootstrap remains on old version)
3.connect host
  
Actual results:
connecting host fails

Expected results:
connecting host succeeds.


Additional info:
Comment 1 Ohad Basan 2012-10-25 10:47:17 EDT
Patch posted upstream:

http://gerrit.ovirt.org/8828
Comment 2 Juan Hernández 2012-10-25 11:42:28 EDT
It would also help to have an error message in the log when the engine can't create the .tar file because of the missing directory.
Comment 5 Itamar Heim 2012-10-26 03:45:58 EDT
(In reply to comment #2)
> It would also help to have an error message in the log when the engine can't
> create the .tar file because of the missing directory.

last time i saw this happen, it actually created an empty tar file.
lets start by requiring it the right version.
Comment 7 Ohad Basan 2012-11-06 11:31:22 EST
Patch to log an error message when the directory is missing has been posted for review
http://gerrit.ovirt.org/9086
Comment 8 Alon Bar-Lev 2012-11-20 04:40:58 EST
(In reply to comment #7)
> Patch to log an error message when the directory is missing has been posted
> for review
> http://gerrit.ovirt.org/9086

This is entirely different issue... should have not been in this bug...

Just saw this now...

It is obsoleted by[1].

[1] http://gerrit.ovirt.org/#/c/9165/
Comment 9 Itamar Heim 2013-01-16 11:08:44 EST
3.2 beta built, moving to ON_QA status to allow testing

Note You need to log in before you can comment on or make changes to this bug.