Bug 870077 - [patch] Update to latest upstream 3.4.1
[patch] Update to latest upstream 3.4.1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse-wtp-servertools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vladimir Kostadinov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 10:17 EDT by Gerard Ryan
Modified: 2012-10-26 08:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-26 08:49:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
git-formatted patch (3.63 KB, patch)
2012-10-25 10:17 EDT, Gerard Ryan
no flags Details | Diff

  None (edit)
Description Gerard Ryan 2012-10-25 10:17:31 EDT
Created attachment 633345 [details]
git-formatted patch

Upstream has released 3.4.1, latest Fedora package is 3.4.0.

There are a couple of little changes in this patch to allow 3.4.1 to be built:

- The script that creates the source tarball (fetch-wtp-servertools.sh) has been changed to fetch sources from git.eclipse.org rather than CVS.

- An orbit dependency has been added since org.eclipse.emf.edit_ bundle now exists in %{_javadir}/emf/eclipse/plugins/ rather than in the eclipse dropins location. It's a  dependency for an eclipse-wtp-common bundle, and when it can't be located, eclipse-wtp-common can't be used as a dependency here.


Once this patch is applied, the fetch-wtp-servertools.sh script will need to be run to fetch new sources.
Comment 1 Vladimir Kostadinov 2012-10-26 08:49:09 EDT
Patch applied. Thanks!

Note You need to log in before you can comment on or make changes to this bug.