Bug 870081 - SELinux is preventing /usr/sbin/sendmail.sendmail from 'getattr' accesses on the file /etc/passwd.
SELinux is preventing /usr/sbin/sendmail.sendmail from 'getattr' accesses on ...
Status: CLOSED DUPLICATE of bug 870080
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:03ea3c237c10e4fe011a8148610...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 10:21 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 13:45:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-25 10:21 EDT, Martin
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-25 10:21 EDT, Martin
no flags Details

  None (edit)
Description Martin 2012-10-25 10:21:46 EDT
Additional info:
libreport version: 2.0.16
kernel:         3.6.3-3.fc18.x86_64

description:
:SELinux is preventing /usr/sbin/sendmail.sendmail from 'getattr' accesses on the file /etc/passwd.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/etc/passwd default label should be passwd_file_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /etc/passwd
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that sendmail.sendmail should be allowed getattr access on the passwd file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep newaliases /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:system_r:system_mail_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:shadow_t:s0
:Target Objects                /etc/passwd [ file ]
:Source                        newaliases
:Source Path                   /usr/sbin/sendmail.sendmail
:Port                          <Neznámé>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    <Neznámé>
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.2-4.fc17.x86_64 #1 SMP Wed Oct
:                              17 02:43:21 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-25 14:15:18 CEST
:Last Seen                     2012-10-25 14:15:18 CEST
:Local ID                      7eb754b8-2f1d-4b7e-a002-3b5aa1180ff2
:
:Raw Audit Messages
:type=AVC msg=audit(1351167318.643:141): avc:  denied  { getattr } for  pid=3470 comm="newaliases" path="/etc/passwd" dev="dm-0" ino=133756 scontext=unconfined_u:system_r:system_mail_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:shadow_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1351167318.643:141): arch=x86_64 syscall=fstat success=yes exit=0 a0=3 a1=7fff17aec070 a2=7fff17aec070 a3=0 items=0 ppid=3468 pid=3470 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=51 sgid=51 fsgid=51 tty=pts0 ses=2 comm=newaliases exe=/usr/sbin/sendmail.sendmail subj=unconfined_u:system_r:system_mail_t:s0-s0:c0.c1023 key=(null)
:
:Hash: newaliases,system_mail_t,shadow_t,file,getattr
:
:audit2allow
:
:#============= system_mail_t ==============
:allow system_mail_t shadow_t:file getattr;
:
:audit2allow -R
:
:#============= system_mail_t ==============
:allow system_mail_t shadow_t:file getattr;
:
Comment 1 Martin 2012-10-25 10:21:49 EDT
Created attachment 633348 [details]
File: type
Comment 2 Martin 2012-10-25 10:21:51 EDT
Created attachment 633349 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-25 13:45:59 EDT

*** This bug has been marked as a duplicate of bug 870080 ***

Note You need to log in before you can comment on or make changes to this bug.