Bug 870089 - perl-IPC-Run3 is missing dependencies to run internal test suite.
Summary: perl-IPC-Run3 is missing dependencies to run internal test suite.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-IPC-Run3
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-25 14:32 UTC by Miroslav Hradílek
Modified: 2012-11-08 18:52 UTC (History)
2 users (show)

(edit)
Cause:
  Running internal perl-IPC-Run3 test suit.
Consequence: 
  Tests calling IPC::Run3 profiler fails.
Fix: 
  Run-time dependencies on perl(Getopt::Long) and
  perl(Time::HiRes) have been added to perl-IPC-Run3
  package because the perl modules are needed by some
  IP::Run3 functions.
Result:
  IPC::Run3 profiler does not die on missing perl modules
  anymore.
Clone Of:
: 1034866 (view as bug list)
(edit)
Last Closed: 2012-11-08 18:52:40 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1440 normal SHIPPED_LIVE perl-IPC-Run3 bug fix update 2012-11-08 23:50:01 UTC
Red Hat Bugzilla 657487 None None None Never

Internal Trackers: 657487

Description Miroslav Hradílek 2012-10-25 14:32:55 UTC
Description of problem:
Internal test suite requires dependencies like perl(Time::HiRes) and perl(Getopt::Long) but perl-IPC-Run3 package does not require these.

Version-Release number of selected component (if applicable):
perl-IPC-Run3-0.043-3.el6.noarch

How reproducible:
Every time

Comment 2 Petr Pisar 2012-10-25 15:00:20 UTC
Indeed the dependencies can be required in some use cases.

Comment 10 errata-xmlrpc 2012-11-08 18:52:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1440.html


Note You need to log in before you can comment on or make changes to this bug.