Bug 870090 - SELinux is preventing /usr/libexec/polkit-1/polkitd from 'getattr' accesses on the file /etc/passwd.
SELinux is preventing /usr/libexec/polkit-1/polkitd from 'getattr' accesses o...
Status: CLOSED DUPLICATE of bug 844167
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e73f19bcd630a47f49aeedfa87a...
:
Depends On:
Blocks: 841451
  Show dependency treegraph
 
Reported: 2012-10-25 10:33 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 11:43:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-25 10:33 EDT, Martin
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-25 10:33 EDT, Martin
no flags Details

  None (edit)
Description Martin 2012-10-25 10:33:24 EDT
Description of problem:
yum distro-sync from F17 to F18
https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum?rd=YumUpgradeFaq#Fedora_17_-.3E_Fedora_18

reproducible: always

workaround: setenforce 0

see more: https://bugzilla.redhat.com/show_bug.cgi?id=844167#c44

how to fix: add proper policy to selinux-policy-3.10.0-xxx.fc17


Additional info:
libreport version: 2.0.16
kernel:         3.6.3-3.fc18.x86_64

description:
:SELinux is preventing /usr/libexec/polkit-1/polkitd from 'getattr' accesses on the file /etc/passwd.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/etc/passwd default label should be passwd_file_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /etc/passwd
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that polkitd should be allowed getattr access on the passwd file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep polkitd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:policykit_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:shadow_t:s0
:Target Objects                /etc/passwd [ file ]
:Source                        polkitd
:Source Path                   /usr/libexec/polkit-1/polkitd
:Port                          <Neznámé>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    <Neznámé>
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.2-4.fc17.x86_64 #1 SMP Wed Oct
:                              17 02:43:21 UTC 2012 x86_64 x86_64
:Alert Count                   6
:First Seen                    2012-10-25 14:02:56 CEST
:Last Seen                     2012-10-25 14:16:29 CEST
:Local ID                      44bfded7-f98e-4ce3-ab72-aa2667ef5d5a
:
:Raw Audit Messages
:type=AVC msg=audit(1351167389.48:148): avc:  denied  { getattr } for  pid=597 comm="polkitd" path="/etc/passwd" dev="dm-0" ino=133756 scontext=system_u:system_r:policykit_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:shadow_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1351167389.48:148): arch=x86_64 syscall=fstat success=yes exit=0 a0=b a1=7fff159cf720 a2=7fff159cf720 a3=0 items=0 ppid=1 pid=597 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=polkitd exe=/usr/libexec/polkit-1/polkitd subj=system_u:system_r:policykit_t:s0-s0:c0.c1023 key=(null)
:
:Hash: polkitd,policykit_t,shadow_t,file,getattr
:
:audit2allow
:
:#============= policykit_t ==============
:allow policykit_t shadow_t:file getattr;
:
:audit2allow -R
:
:#============= policykit_t ==============
:allow policykit_t shadow_t:file getattr;
:
Comment 1 Martin 2012-10-25 10:33:27 EDT
Created attachment 633369 [details]
File: type
Comment 2 Martin 2012-10-25 10:33:30 EDT
Created attachment 633370 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-25 11:43:15 EDT

*** This bug has been marked as a duplicate of bug 844167 ***

Note You need to log in before you can comment on or make changes to this bug.