Bug 870092 - SELinux is preventing /usr/bin/dbus-daemon (deleted) from 'getattr' accesses on the file /etc/passwd.
SELinux is preventing /usr/bin/dbus-daemon (deleted) from 'getattr' accesses ...
Status: CLOSED DUPLICATE of bug 870080
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e87ff7aa9ce6395664279819d16...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 10:34 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 13:47:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-25 10:34 EDT, Martin
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-25 10:34 EDT, Martin
no flags Details

  None (edit)
Description Martin 2012-10-25 10:34:25 EDT
Additional info:
libreport version: 2.0.16
kernel:         3.6.3-3.fc18.x86_64

description:
:SELinux is preventing /usr/bin/dbus-daemon (deleted) from 'getattr' accesses on the file /etc/passwd.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/etc/passwd default label should be passwd_file_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /etc/passwd
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that dbus-daemon (deleted) should be allowed getattr access on the passwd file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:shadow_t:s0
:Target Objects                /etc/passwd [ file ]
:Source                        dbus-daemon
:Source Path                   /usr/bin/dbus-daemon (deleted)
:Port                          <Neznámé>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    <Neznámé>
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.2-4.fc17.x86_64 #1 SMP Wed Oct
:                              17 02:43:21 UTC 2012 x86_64 x86_64
:Alert Count                   9
:First Seen                    2012-10-25 14:02:55 CEST
:Last Seen                     2012-10-25 14:17:32 CEST
:Local ID                      cb841264-c748-4169-affb-68260605fc87
:
:Raw Audit Messages
:type=AVC msg=audit(1351167452.177:154): avc:  denied  { getattr } for  pid=579 comm="dbus-daemon" path="/etc/passwd" dev="dm-0" ino=133756 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:shadow_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1351167452.177:154): arch=x86_64 syscall=fstat success=yes exit=0 a0=38 a1=7fff1a3de730 a2=7fff1a3de730 a3=0 items=0 ppid=1 pid=579 auid=4294967295 uid=81 gid=81 euid=81 suid=81 fsuid=81 egid=81 sgid=81 fsgid=81 tty=(none) ses=4294967295 comm=dbus-daemon exe=2F7573722F62696E2F646275732D6461656D6F6E202864656C6574656429 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: dbus-daemon,system_dbusd_t,shadow_t,file,getattr
:
:audit2allow
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t shadow_t:file getattr;
:
:audit2allow -R
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t shadow_t:file getattr;
:
Comment 1 Martin 2012-10-25 10:34:31 EDT
Created attachment 633374 [details]
File: type
Comment 2 Martin 2012-10-25 10:34:34 EDT
Created attachment 633375 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-25 13:47:26 EDT

*** This bug has been marked as a duplicate of bug 870080 ***

Note You need to log in before you can comment on or make changes to this bug.