Bug 870100 - Incomplete error message “Could not find value for user. Going to use default v alue of:” during run vm [TEXT]
Incomplete error message “Could not find value for user. Going to use default...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 All
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Omer Frenkel
Pavel Stehlik
virt
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-10-25 10:40 EDT by vvyazmin@redhat.com
Modified: 2013-10-30 21:16 EDT (History)
12 users (show)

See Also:
Fixed In Version: sf2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm (1.03 MB, application/octet-stream)
2012-10-25 10:40 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2012-10-25 10:40:52 EDT
Created attachment 633381 [details]
## Logs rhevm

Description of problem:
Incomplete error message “Could not find value for user. Going to use default v
alue of:” during import ISO Domain 

Version-Release number of selected component (if applicable):
RHEVM 3.1 - SI22

RHEVM: rhevm-3.1.0-22.el6ev.noarch
VDSM: vdsm-4.9.6-39.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.5.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6_3.2.x86_64
SANLOCK: sanlock-2.3-4.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a new DC
2. Import ISO Domain
  
Actual results:
Action succeed import ISO Domain, but in engine.log get en error “Could not find value for user. Going to use default v
alue of:” 

Expected results:
No Error in RHEVM logs

Additional info:

2012-10-25 13:01:08,439 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IsoPrefixVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] START, IsoPrefixVDSCommand( storagePoolId = 7455040b-1fe6-4434-95a4-57cab522d76e, ignoreFailoverLimit = false, compatabilityVersion = null), log id: 4d5f0e24
2012-10-25 13:01:08,474 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IsoPrefixVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] FINISH, IsoPrefixVDSCommand, return: /rhev/data-center/7455040b-1fe6-4434-95a4-57cab522d76e/7233a711-98e8-4c3c-bcfa-44c4bcc4f6c6/images/11111111-1111-1111-1111-111111111111, log id: 4d5f0e24
2012-10-25 13:01:08,781 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IsValidVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] START, IsValidVDSCommand( storagePoolId = 7455040b-1fe6-4434-95a4-57cab522d76e, ignoreFailoverLimit = false, compatabilityVersion = null), log id: 7f29380a
2012-10-25 13:01:08,785 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IsValidVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] FINISH, IsValidVDSCommand, return: true, log id: 7f29380a
2012-10-25 13:01:09,130 INFO  [org.ovirt.engine.core.vdsbroker.IsVmDuringInitiatingVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] START, IsVmDuringInitiatingVDSCommand( vmId = 67ca9c19-fd90-4b2f-8389-f1f86e969c98), log id: 3267cfad
2012-10-25 13:01:09,130 INFO  [org.ovirt.engine.core.vdsbroker.IsVmDuringInitiatingVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] FINISH, IsVmDuringInitiatingVDSCommand, return: false, log id: 3267cfad
2012-10-25 13:01:09,358 INFO  [org.ovirt.engine.core.bll.RunVmOnceCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] Running command: RunVmOnceCommand internal: false. Entities affected :  ID: 67ca9c19-fd90-4b2f-8389-f1f86e969c98 Type: VM
2012-10-25 13:01:09,397 INFO  [org.ovirt.engine.core.vdsbroker.CreateVmVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] START, CreateVmVDSCommand(HostName = cougar08.scl.lab.tlv.redhat.com, HostId = a15dc4b8-1dcd-11e2-acc9-001a4a169738, vmId=67ca9c19-fd90-4b2f-8389-f1f86e969c98, vm=org.ovirt.engine.core.common.businessentities.VM@61189008), log id: 188478c1
2012-10-25 13:01:09,413 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SysprepHandler] (ajp-/127.0.0.1:8702-9) [3f85bd8a] Could not find value for user. Going to use default value of: 
2012-10-25 13:01:09,415 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVmFromSysPrepVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] START, CreateVmFromSysPrepVDSCommand(HostName = cougar08.scl.lab.tlv.redhat.com, HostId = a15dc4b8-1dcd-11e2-acc9-001a4a169738, vmId=67ca9c19-fd90-4b2f-8389-f1f86e969c98, vm=org.ovirt.engine.core.common.businessentities.VM@61189008, hostName=vm-Win7, domain=), log id: 33651a
2012-10-25 13:01:09,536 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVmFromSysPrepVDSCommand spiceSslCipherSuite=DEFAULT,memSize=2048,kvmEnable=true,smp=1,emulatedMachine=rhel6.3.0,vmType=kvm,keyboardLayout=en-us,nice=0,display=qxl,smpCoresPerSocket=1,spiceSecureChannels=smain,sinputs,scursor,splayback,srecord,sdisplay,susbredir,ssmartcard,timeOffset=-43200,transparentHugePages=true,vmId=67ca9c19-fd90-4b2f-8389-f1f86e969c98,devices=[Ljava.util.Map;@73c634c3,acpiEnable=true,vmName=vm-Win7,cpuType=Opteron_G3,custom={}
2012-10-25 13:01:09,536 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVmFromSysPrepVDSCommand] (ajp-/127.0.0.1:8702-9) [3f85bd8a] FINISH, CreateVmFromSysPrepVDSCommand, log id: 33651a
Comment 1 Itamar Heim 2012-10-25 16:31:06 EDT
the error in the log is from a RunVM command, unrealted to import iso domain?

this is sysprep handler trying to fetch the default values for syspre user/domain/password, if not passed any specific ones for the domain.
and the default happens to be empty (maybe should have '' around the value side).
Comment 2 Omer Frenkel 2012-10-29 07:43:36 EDT
http://gerrit.ovirt.org/#/c/8890
Comment 5 Oded Ramraz 2013-01-28 08:18:23 EST
Can't reproduce sf4
Comment 6 Itamar Heim 2013-06-11 05:04:01 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 05:04:01 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 05:04:07 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 05:04:29 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 05:33:32 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.