Bug 870126 - Reinstall_with_IO fails in Windows 7 WHQL testing
Reinstall_with_IO fails in Windows 7 WHQL testing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Alon Levy
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 11:28 EDT by Bill Sanford
Modified: 2012-10-31 10:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-31 10:07:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The setupapi app and dev logs (13.32 MB, application/x-gzip)
2012-10-25 11:36 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2012-10-25 11:28:49 EDT
Description of problem:
The Reinstall_with_IO tests fail in Windows 7 32&64 bit guests. 

This was originally filed with Microsoft and the erratum 1375 that was previously entered is no longer available from 
(https://winqual.microsoft.com/EC/ECDetails.aspx?id=3265), it is also no longer available from the new dashboard in sysdev.microsoft.com. 

Version-Release number of selected component (if applicable):
RHEV-M si20
qemu-kvm-rhev-0.12.1.2-2.295.el6_3.2.x86_64
qemu-kvm-rhev-tools-0.12.1.2-2.295.el6_3.2.x86_64
kernel-2.6.32-279.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run the unclassified test suite from WHQL.
2.
3.
  
Actual results:
Reintall_with_IO test fails

Expected results:
Reintall_with_IO test passes.

Additional info:

[root@giediprime ~]# ps aux | grep qemu
qemu      3990  0.0  0.0      0     0 ?        Z<   Oct09   0:00 [python] <defunct>
qemu     23567 11.4 27.2 2649972 2192016 ?     Sl   09:20   6:14 /usr/libexec/qemu-kvm -S -M rhel6.3.0 -cpu Nehalem -enable-kvm -m 2048 -smp 1,sockets=1,cores=1,threads=1 -name Win7x64-whql16 -uuid 1ddb26c7-651c-4f7e-8f44-cef3c05ff23c -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=6Server-6.3.0.3.el6,serial=33221100-5544-7766-8899-AABBCCDDEEFF_1C:C1:DE:FA:AD:8C,uuid=1ddb26c7-651c-4f7e-8f44-cef3c05ff23c -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/Win7x64-whql16.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2012-10-25T14:17:36,driftfix=slew -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=/rhev/data-center/72a604c2-1239-11e2-9d40-52540053bfec/a9e6b327-1051-4689-a3ea-69286058ef6b/images/93a07005-caff-46d9-aec2-fa4062abc90b/ae89d41c-c85f-446a-a554-a8a9a768a4e8,if=none,id=drive-ide0-0-0,format=raw,serial=93a07005-caff-46d9-aec2-fa4062abc90b,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/rhev/data-center/72a604c2-1239-11e2-9d40-52540053bfec/e1a50b62-693a-412c-bffd-2c9147e4c5b4/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.1_7.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=26,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:1a:4a:10:18:a4,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/Win7x64-whql16.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/Win7x64-whql16.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -chardev pty,id=charconsole0 -device virtconsole,chardev=charconsole0,id=console0 -spice port=5900,tls-port=5901,addr=0,x509-dir=/etc/pki/vdsm/libvirt-spice,tls-channel=main,tls-channel=display,tls-channel=inputs,tls-channel=cursor,tls-channel=playback,tls-channel=record,tls-channel=smartcard,tls-channel=usbredir -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
root     28699  0.0  0.0 103244   864 pts/2    S+   10:15   0:00 grep qemu
[root@giediprime ~]#
Comment 1 Bill Sanford 2012-10-25 11:36:14 EDT
Created attachment 633414 [details]
The setupapi app and dev logs
Comment 2 Yan Vugenfirer 2012-10-26 11:29:37 EDT
What kind of the device is under test?

In any case - Mike, please refile the ERRATA with MS.
Comment 3 Bill Sanford 2012-10-26 11:42:16 EDT
I was testing qxl-win-unsigned-0.1-16 at https://brewweb.devel.redhat.com/buildinfo?buildID=238767.
Comment 4 Mike Cao 2012-10-26 12:26:30 EDT
Hi, Bill

Which testing kit are you using ? WLK1.6 or HCK ?
Since you are running whql test on qxl driver ,Why report it on virito-win component instead of qxl conponent ?

Thanks, 
Mike
Comment 5 Bill Sanford 2012-10-26 13:05:51 EDT
I am using WLK 1.6. 

The reason I am not putting it against the QXL is that if I switch the protocol in RHEV-M from SPICE to VNC, then start the VM and retest, the QXL driver that is in the VM passes the test.
Comment 6 Mike Cao 2012-10-26 13:41:06 EDT
(In reply to comment #5)
> I am using WLK 1.6. 
> 
> The reason I am not putting it against the QXL is that if I switch the
> protocol in RHEV-M from SPICE to VNC, then start the VM and retest, the QXL
> driver that is in the VM passes the test.

I still think it is a QXL driver issue .AFAIK RHEVM does not support use qxl driver for vnc (eg in <qemu commandline> -vnc :3 -vga qxl is not supported)
When you use VNC  ,you can check it in device manager, I think system now does not use QXL driver ,which make your  job can pass successfully

I check the jobs you attached
     sig:      {_VERIFY_FILE_SIGNATURE} 16:28:17.876
     sig:           Key      = qxl.inf
     sig:           FilePath = C:\Windows\System32\DriverStore\FileRepository\qxl.inf_amd64_neutral_f562e637c4062036\qxl.inf
     sig:           Catalog  = C:\Windows\System32\DriverStore\FileRepository\qxl.inf_amd64_neutral_f562e637c4062036\qxl.cat
!    sig:           Verifying file against specific (valid) catalog failed! (0x800b0109)
!    sig:           Error 0x800b0109: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.
     sig:      {_VERIFY_FILE_SIGNATURE exit(0x800b0109)} 16:28:18.220
     sig:      {_VERIFY_FILE_SIGNATURE} 16:28:18.220
     sig:           Key      = qxl.inf
     sig:           FilePath = C:\Windows\System32\DriverStore\FileRepository\qxl.inf_amd64_neutral_f562e637c4062036\qxl.inf
     sig:           Catalog  = C:\Windows\System32\DriverStore\FileRepository\qxl.inf_amd64_neutral_f562e637c4062036\qxl.cat
     sig:           Success: File is signed in Authenticode(tm) catalog.
     sig:           Error 0xe0000242: The publisher of an Authenticode(tm) signed catalog has not yet been established as trusted.

All failed are related to QXL driver ,so I think this is a QXL driver bug 

Yan ,Can you view the logs Bill attached and check whether am I right
Comment 7 Alon Levy 2012-10-28 09:17:50 EDT
Bill, Mike,

 Like Bill said originally, this is a known issue that was a problem with the testing suite, not the qxl driver, and got an erratum from Microsoft. I understand from comment #1 that that erratum is now expired.

 I +1 the request to renew it - I have no idea who is in charge of doing it, I filed the original one, but hopefully it doesn't mean I have to renew it ;)

 Of course, first need to see that the logs are the same - but why would it be in the setupapi.{dev,app}.log files? the relevant errors are in the WHQL logs afair.

 I don't remember seeing the certificate problem you are pointing out - it seems to me not to be related to the subject anyway.

Alon
Comment 9 Mike Cao 2012-10-30 02:07:20 EDT
Bill , Could you attach .cpk file for the failed job in the attachment?

Thanks,
Mike
Comment 10 Mike Cao 2012-10-30 02:46:30 EDT
Feed back from Microsoft


<MSFT>I found the product you are asking for is Windows Logo Kit 1.6. However, the channel through which this case was created  is designed to support WHCK(Windows Hardware Certification Kit).

 

http://msdn.microsoft.com/en-US/library/windows/hardware/hh852377

 
Support

Q: How can I open a support case?

You can open a premier support case with your TAM. Or, you can go to https://support.microsoft.com/oas/default.aspx?&prid=11880   and sign in with your Microsoft account.

For the Windows HCK support options, go to https://support.microsoft.com/oas/default.aspx?&prid=14634

 

And Windows Logo Kit (WLK) is not in the list of this type of free-support cases. If this is an issue which is only available on Windows Logo Kit 1.6. You can still get help by submitting a Service Request by a professional case or a premier support case.

 

 

Would you please let us know if your issue is able to be reproduced by WHCK? Note that WHCK can be used to test these systems:

    Windows 8 x86 and x64
    Windows RT (ARM-based)
    Windows Server 2012 x64
    Windows 7 x86 and x64
    Windows Server 2008 R2 x64
    Windows Vista x86 and x64 (Certification not supported—drivers can be submitted for signing only)
    Windows Server 2008 x86 and x64 (Certification not supported—drivers can be submitted for signing only)
    Windows XP x86 and x64 (Certification not supported—drivers can be submitted for signing only)
    Windows Server 2003 x86 and x64 (Certification not supported—drivers can be submitted for signing only)

 

 
Yan\Alon\Bill ,I don't have MSDN account to initiating a Microsoft professional case ,Pls find someone to do it 

Thanks,
Mike
Comment 11 Alon Levy 2012-10-30 15:31:49 EDT
Hi Mike,

 I have no experience with WHCK (looks like a rebranded WLK?); I do have a MSDN account. Are you trying to reproduce with WHCK? is that good enough, i.e. can we get certified with WHCK?

Alon
Comment 12 Mike Cao 2012-10-30 22:56:58 EDT
(In reply to comment #11)
> Hi Mike,
> 
>  I have no experience with WHCK (looks like a rebranded WLK?); I do have a
> MSDN account. Are you trying to reproduce with WHCK? is that good enough,
> i.e. can we get certified with WHCK?
> 
> Alon

Alon

Requesting WLK errata need MSDN account according to MSFT .you can visit https://support.microsoft.com/oas/default.aspx?&prid=11880 to initiating a Microsoft professional (this is nothing related to WHCK).

WHCK (windows hardware certification kit ) is the substitute products of WLK. WLK will be expired soon .
Ronen suggest me use WLK to run RHEL6.4 virtio-win whql jobs .since we find lots of new bugs on HCK.

I can help to run this job on HCK but it is meanless .even this job passed on HCK ,other jobs may failed due to HCK issue (that's the reason why we use WLK1.6 to certify rhel6.4 virtio-win drivers).I suggest Spice team make a decision which tool used to run WHQL jobs and do further research on it
Comment 13 Bill Sanford 2012-10-31 10:07:56 EDT
In a RHEV-M setup, I can stop the VM, switch the protocol from SPICE to VNC and then this test will pass.

Note You need to log in before you can comment on or make changes to this bug.