Bug 870153 - [ja_JP] Test case failure: Virtual Machines [LAYOUT]: New VM dialog -> Resrouce Allocation section -> string "clone" is broken into two lines
[ja_JP] Test case failure: Virtual Machines [LAYOUT]: New VM dialog -> Resrou...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Linux
high Severity high
: ---
: 3.2.0
Assigned To: Shahar Havivi
Yuko Katabami
ux
: i18n, ZStream
Depends On:
Blocks: 887856 915537
  Show dependency treegraph
 
Reported: 2012-10-25 12:27 EDT by Yuko Katabami
Modified: 2013-06-11 05:42 EDT (History)
11 users (show)

See Also:
Fixed In Version: sf1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 887856 (view as bug list)
Environment:
Last Closed: 2013-06-11 05:18:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot is FIXED (yellow line marked) (43.51 KB, image/png)
2012-11-30 09:31 EST, A S Alam
no flags Details
screen shot: New VM - Clone Allocation (Japanese) - not fixed (38.91 KB, image/png)
2012-12-04 15:35 EST, Einav Cohen
no flags Details
Fixed New Server-Resource Allocation subtab (41.45 KB, image/png)
2013-01-08 23:17 EST, Lijun Li
no flags Details

  None (edit)
Description Yuko Katabami 2012-10-25 12:27:02 EDT
Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
unspecified

Steps to Reproduce: 
  * Portal should be in Local Language


  * Click on Virtual Machines Tab
  * Click Column Header with translated text (for truncated text)
  * Click on Each Action (button), check Dialog box and tabs within dialog box

Note: Please skip action if it is not active (to click)

      + New Server => Resource Allocation subtab


Actual results: 
#FIXME
Radio button item "Clone" is spread over two lines.

Expected results:
Should be in one line, aligned with "Thin" radio button
Comment 1 Shahar Havivi 2012-10-28 10:42:34 EDT
posted at: http://gerrit.ovirt.org/#/c/8867/
Comment 2 Oved Ourfali 2012-10-28 12:27:19 EDT
Commit: dd40e0cf3a932e7f4985fed08f6c6626c947f4ac

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=dd40e0cf3a932e7f4985fed08f6c6626c947f4ac
Comment 4 Yuko Katabami 2012-10-29 10:41:25 EDT
Received request Japan to change the translation of "Thin", which is a radio button item right next to "Clone".

Current translation is "シン"
It needs to be changed to "シンプロビジョニング"
Changed in zanata already, however we realized that this would cause a layout issue.
Please check and make necessary changes.

Also please note that this is applicable to both server and desktop VM edit/create windows.
Comment 5 Einav Cohen 2012-10-30 13:55:45 EDT
(In reply to comment #4)
> Received request Japan to change the translation of "Thin", which is a radio
> button item right next to "Clone".
> 
> Current translation is "シン"
> It needs to be changed to "シンプロビジョニング"
> Changed in zanata already, however we realized that this would cause a
> layout issue.
> Please check and make necessary changes.
> 
> Also please note that this is applicable to both server and desktop VM
> edit/create windows.

BZ verifier: I am not sure if si23 contains the updated translation. If not - please move this BZ back to ASSIGNED with the relevant explanation.
Comment 6 A S Alam 2012-11-30 09:31:14 EST
Created attachment 655082 [details]
screenshot is FIXED (yellow line marked)
Comment 7 A S Alam 2012-11-30 09:33:22 EST
This bug is fixed.
Comment 8 Yuko Katabami 2012-12-01 03:22:34 EST
Screen shot does not contain the updated translation.
New translation is in Zanata, but the screen has the old one.
シン has to be changed to シンプロビジョニング
Please note that this is one of change requests from solution architect in Red Hat Japan.
Comment 9 A S Alam 2012-12-01 04:06:35 EST
based on comment #8, bug is moved to Assigned to pull latest translation.
Comment 11 Einav Cohen 2012-12-02 21:21:59 EST
Hi Yuko, is the updated japanese string already exists in the "master" version of the oVirt Zanata project? If so, when was it updated?
Comment 12 Yuko Katabami 2012-12-02 22:18:21 EST
(In reply to comment #11)
> Hi Yuko, is the updated japanese string already exists in the "master"
> version of the oVirt Zanata project? If so, when was it updated?

Hi Einav,

This string was updated in Zanata on 26 Oct.
It exists in both master and rhevm-3.1 versions.
Comment 13 Einav Cohen 2012-12-03 10:52:43 EST
Thanks Yuko - it means that the updated Japanese string must exist in my latest oVirt patch [http://gerrit.ovirt.org/#/c/9610/].

Shahar - can you please apply http://gerrit.ovirt.org/#/c/9610/ on latest upstream and see if the bug is fixed even with the updated Japanese string (see comment #8)?
Comment 14 Einav Cohen 2012-12-04 15:35:22 EST
Created attachment 657710 [details]
screen shot: New VM - Clone Allocation (Japanese) - not fixed
Comment 15 Einav Cohen 2012-12-04 15:41:49 EST
tested: with the updated (longer) Japanese string, the problem is still not solved - see attachment 657710 [details]
[screen-shot is from oVirt and not from RHEV-M, but I suspect that the problem would be identical]

Shahar - can you please fix it for the updated (longer) Japanese string?
Thanks.
Comment 16 Shahar Havivi 2012-12-05 06:44:28 EST
New patch send upstream: http://gerrit.ovirt.org/#/c/9742/
Comment 20 Lijun Li 2012-12-26 07:06:46 EST
Verified. It's fixed on RHEVM3.2 sf1 build.
[root@dhcp-8-215 ~]# rpm -q rhevm
rhevm-3.2.0-1.el6ev.noarch
[root@dhcp-8-215 ~]# rpm -q rhevm-webadmin-portal
rhevm-webadmin-portal-3.2.0-1.el6ev.noarch
Please see the attached screenshot.

Thanks,
Robert
Comment 22 Einav Cohen 2013-01-08 22:56:15 EST
(In reply to comment #20)
> Please see the attached screenshot.

Lijun Li[/Robert]: Can you please provide the screen-shot?

(In reply to comment #21)
> The string "Clone" is fine as Robert reported, however "シンプロビジョニング" (Thin)
> is broken into two lines. It still needs to be fixed.

Yuko:

this issue was fixed by aligning the "thin" and "clone" radio-buttons vertically
[i.e.:
( ) thin
(*) clone]

instead of horizontally
[i.e.:
( ) thin   (*) clone]

which should, theoretically, leave plenty of room for the Japanese "thin" string.

are you sure that you are looking at the correct version (i.e. rhev-m 3.2, sf1 or later)? 

again - a screen-shot would be helpful here. If indeed the bug hasn't been fixed, this BZ should be re-opened.
Comment 23 Lijun Li 2013-01-08 23:12:48 EST
(In reply to comment #22)
> (In reply to comment #20)
> > Please see the attached screenshot.
> 
> Lijun Li[/Robert]: Can you please provide the screen-shot?

Hi Einav, 
Sorry forgot to attach the screenshot, confirmed that it's fixed on the latest sf build.

[root@rhevm32 ~]# rpm -q rhevm rhevm-webadmin-portal
rhevm-3.2.0-4.el6ev.noarch
rhevm-webadmin-portal-3.2.0-4.el6ev.noarch

Please refer to the attached screenshot.

Thanks,
Robert


> 
> (In reply to comment #21)
> > The string "Clone" is fine as Robert reported, however "シンプロビジョニング" (Thin)
> > is broken into two lines. It still needs to be fixed.
> 
> Yuko:
> 
> this issue was fixed by aligning the "thin" and "clone" radio-buttons
> vertically
> [i.e.:
> ( ) thin
> (*) clone]
> 
> instead of horizontally
> [i.e.:
> ( ) thin   (*) clone]
> 
> which should, theoretically, leave plenty of room for the Japanese "thin"
> string.
> 
> are you sure that you are looking at the correct version (i.e. rhev-m 3.2,
> sf1 or later)? 
> 
> again - a screen-shot would be helpful here. If indeed the bug hasn't been
> fixed, this BZ should be re-opened.
Comment 24 Lijun Li 2013-01-08 23:17:03 EST
Created attachment 675237 [details]
Fixed New Server-Resource Allocation subtab
Comment 25 Einav Cohen 2013-01-08 23:27:29 EST
Thanks Lijun Li[/Robert] - according to the screen-shot, the radio-buttons' alignment has changed to be vertical, which leaves plenty of room for the Japanese strings (as I mentioned in my previous comment).

So the bug can remain in VERIFIED then.
Comment 27 Itamar Heim 2013-06-11 05:18:04 EDT
3.2 has been released
Comment 28 Itamar Heim 2013-06-11 05:42:15 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.