Bug 870180 - Assertion 'prefix' failed at src/shared/path-util.c:269, function path_startswith()
Assertion 'prefix' failed at src/shared/path-util.c:269, function path_starts...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18systemd
  Show dependency treegraph
 
Reported: 2012-10-25 14:00 EDT by Tim Flink
Modified: 2012-12-05 12:36 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 12:36:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2012-10-25 14:00:12 EDT
When booting the upgrade.img produced by fedup (new Fedora upgrade tool) and systemd-194-1.fc18, a systemd failure during boot causes systemd to crash, preventing the upgrade process.

Error message on console:
Assertion 'prefix' failed at src/shared/path-util.c:269, function path_startswith(). Aborting.


The fix is already in upstream systemd git:
http://cgit.freedesktop.org/systemd/systemd/commit/?id=bcbd5405b1b6d9d219259e3be2c3ec4d92812bcb

This fix is definitely present in systemd-195-4 (upgrade.img built with 195-4 doesn't crash) but any version with the needed fix would solve the issue.
Comment 1 Tim Flink 2012-10-25 14:01:24 EDT
Proposing as a blocker for F18 beta due to violation of the following F18 beta release criterion [1]:

For each one of the release-blocking package sets ('minimal', and the package sets for each one of the release-blocking desktops), it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using any officially recommended upgrade mechanisms. The upgraded system must meet all release criteria. 

[1] http://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 2 Michal Schmidt 2012-12-05 12:36:07 EST
> This fix is definitely present in systemd-195-4 (upgrade.img built with
> 195-4 doesn't crash) but any version with the needed fix would solve the
> issue.

A higher version is now in F18, so this should be closed.

Note You need to log in before you can comment on or make changes to this bug.