Bug 870184 - Review Request: drumkv1 - an old-school digital drumkit sampler
Review Request: drumkv1 - an old-school digital drumkit sampler
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Volker Fröhlich
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraAudio
  Show dependency treegraph
 
Reported: 2012-10-25 14:11 EDT by Brendan Jones
Modified: 2012-12-01 03:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 00:12:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
volker27: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Brendan Jones 2012-10-25 14:11:52 EDT
drumkv1 is an old-school all-digital drum-kit sampler synthesizer with stereo fx.
It comes in standalone or LV2 flavours

SRPM: http://bsjones.fedorapeople.org/drumkv1.spec
SRPM: http://bsjones.fedorapeople.org/drumkv1-0.1.0-1.fc18.src.rpm

drumkv1.src: W: spelling-error %description -l en_US fx -> f, x, fix
drumkv1.x86_64: W: spelling-error %description -l en_US fx -> f, x, fix
drumkv1.x86_64: W: no-manual-page-for-binary drumkv1_jack
lv2-drumkv1.x86_64: W: spelling-error %description -l en_US synth -> synthesis
lv2-drumkv1.x86_64: W: no-documentation
3 packages and 0 specfiles checked; 0 errors, 5 warnings.
Comment 1 Volker Fröhlich 2012-10-25 17:59:30 EDT
desktop file validation belongs in the install section; no check section required.

I suggest to include ChangeLog.

Please give a rationale for changing the compiler flags. Is it possibly something upstream should incorporate?

Since Fedora has no older version of lv2 than 1.0.0, the version requirement is not necessary.

It seems like the hidden .ui and .moc files are still present in the debuginfo package.

You could use the version macro in Source0 one more time.

make %{?_smp_mflags} seems to work for me.
Comment 2 Brendan Jones 2012-10-25 23:53:57 EDT
Thanks for the comments - changed as requested


SRPM: http://bsjones.fedorapeople.org/drumkv1.spec
SRPM: http://bsjones.fedorapeople.org/drumkv1-0.1.0-2.fc18.src.rpm
Comment 4 Volker Fröhlich 2012-11-17 15:26:01 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=4699000 -- Rawhide build

There's no reason for a version constraint on lv2. No maintained release of Fedora has an older version than 1.0.0.

I was wrong about the hidden files in the debugging package. They are vital to debugging and it's a habit of Qmake to hide them. Please don't delete them.

Please report the issue of wrong permissions of the .so upstream.

I assume, the lv2 plug-in doesn't require the base package.

Please see the review below for further details.

Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

C/C++:
[x]: Header files in -devel subpackage, if present.
[x]: Package does not contain any libtool archives (.la)
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.
     Note: Unversioned so-files in private %_libdir subdirectory (see
     attachment). Verify they are not in ld path.

Plug-in library in a sub-directory

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package contains desktop file if it is a GUI application.
[x]: Package installs a %{name}.desktop using desktop-file-install if there is
     such a file.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[!]: Package is not known to require ExcludeArch.

ppc64 build fails:
http://ppc.koji.fedoraproject.org/koji/getfile?taskID=789144&name=build.log

[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in %package -n
     lv2-%{name}

See comment at the top!

[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "GPL (v2 or later)". 1 files have unknown license. Detailed output of
     licensecheck in
     /media/speicher1/makerpm/rpmbuild/SPECS/870184-drumkv1/licensecheck.txt
[!]: License file installed when any subpackage combination is installed.

Please add COPYING to the lv2 sub-package!

[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[x]: Useful -debuginfo package or justification otherwise.
[-]: Large documentation must go in a -doc subpackage.
     Note: Test run failed
[x]: Packages must not store files under /srv, /opt or /usr/local
     Note: Test run failed

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: Scriptlets must be sane, if used.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX / PatchY prefixed with %{name}.
[x]: SourceX is a working URL.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
PPC is no primary architecture in Fedora

[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.
[-]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
     Note: Test run failed


Rpmlint
-------
Checking: drumkv1-debuginfo-0.1.0-3.fc19.x86_64.rpm
          drumkv1-0.1.0-3.fc19.x86_64.rpm
          drumkv1-0.1.0-3.fc19.src.rpm
drumkv1.x86_64: W: spelling-error %description -l en_US fx -> f, x, fix
drumkv1.x86_64: W: no-manual-page-for-binary drumkv1_jack
drumkv1.src: W: spelling-error %description -l en_US fx -> f, x, fix
3 packages and 0 specfiles checked; 0 errors, 3 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint drumkv1 drumkv1-debuginfo
drumkv1.x86_64: W: spelling-error %description -l en_US fx -> f, x, fix
drumkv1.x86_64: W: no-manual-page-for-binary drumkv1_jack
2 packages and 0 specfiles checked; 0 errors, 2 warnings.
# echo 'rpmlint-done:'



Requires
--------
drumkv1-debuginfo-0.1.0-3.fc19.x86_64.rpm (rpmlib, GLIBC filtered):
    

drumkv1-0.1.0-3.fc19.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    hicolor-icon-theme  
    libQtCore.so.4()(64bit)  
    libQtGui.so.4()(64bit)  
    libQtXml.so.4()(64bit)  
    libasound.so.2()(64bit)  
    libasound.so.2(ALSA_0.9)(64bit)  
    libc.so.6()(64bit)  
    libgcc_s.so.1()(64bit)  
    libgcc_s.so.1(GCC_3.0)(64bit)  
    libjack.so.0()(64bit)  
    libm.so.6()(64bit)  
    libpthread.so.0()(64bit)  
    libsndfile.so.1()(64bit)  
    libsndfile.so.1(libsndfile.so.1.0)(64bit)  
    libstdc++.so.6()(64bit)  
    libstdc++.so.6(CXXABI_1.3)(64bit)  
    rtld(GNU_HASH)  



Provides
--------
drumkv1-debuginfo-0.1.0-3.fc19.x86_64.rpm:
    
    drumkv1-debuginfo = 0.1.0-3.fc19
    drumkv1-debuginfo(x86-64) = 0.1.0-3.fc19

drumkv1-0.1.0-3.fc19.x86_64.rpm:
    
    drumkv1 = 0.1.0-3.fc19
    drumkv1(x86-64) = 0.1.0-3.fc19



Unversioned so-files
--------------------
lv2-drumkv1-0.1.0-3.fc19.x86_64.rpm: /usr/lib64/lv2/drumkv1.lv2/drumkv1.so

MD5-sum check
-------------
http://downloads.sourceforge.net/project/drumkv1/0.1.0/drumkv1-0.1.0.tar.gz :
  CHECKSUM(SHA256) this package     : f148bc08bfb9f45425259e9feae17cb18bc63cd491036a08d51e37838e475f32
  CHECKSUM(SHA256) upstream package : f148bc08bfb9f45425259e9feae17cb18bc63cd491036a08d51e37838e475f32


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 870184 -m fedora-devel-x86_64
Comment 5 Brendan Jones 2012-11-17 17:18:27 EST
Thanks for taking this on.

I've addressed the issues here. Good catch on the power PC build. This applies to a number of other packages from the same author. I'll let him know

%changelog
* Sat Nov 17 2012 Brendan Jones <brendan.jones.it@gmail.com> 0.1.0-4
- Renable hidden source directories
- Add COPYING to lv2 plugin
- Force LV2 path in configure
- Correct arch handling
- Remove explicit version requires on lv2


SRPM: http://bsjones.fedorapeople.org/reviews/drumkv1.spec
SRPM: http://bsjones.fedorapeople.org/reviews/drumkv1-0.1.0-4.fc18.src.rpm
Comment 6 Volker Fröhlich 2012-11-18 03:16:52 EST
All issues addressed, APPROVED.
Comment 7 Brendan Jones 2012-11-18 03:59:02 EST
New Package SCM Request
=======================
Package Name: drumkv1
Short Description: Digital drumkit sampler for JACK
Owners: bsjones
Branches:f16 f17 f18
InitialCC:
Comment 8 Brendan Jones 2012-11-18 03:59:37 EST
Thanks for the review. Let me know if I can help you out.
Comment 9 Jon Ciesla 2012-11-18 12:11:05 EST
Git done (by process-git-requests).
Comment 10 Fedora Update System 2012-11-18 15:09:07 EST
drumkv1-0.1.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/drumkv1-0.1.0-4.fc18
Comment 11 Fedora Update System 2012-11-18 15:09:18 EST
drumkv1-0.1.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/drumkv1-0.1.0-4.fc17
Comment 12 Fedora Update System 2012-11-18 21:26:26 EST
Package drumkv1-0.1.0-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing drumkv1-0.1.0-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18458/drumkv1-0.1.0-4.fc17
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-11-19 08:41:30 EST
drumkv1-0.1.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/drumkv1-0.1.0-5.fc18
Comment 14 Fedora Update System 2012-11-19 08:42:48 EST
drumkv1-0.1.0-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/drumkv1-0.1.0-5.fc17
Comment 15 Fedora Update System 2012-11-27 00:12:45 EST
drumkv1-0.1.0-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-12-01 03:28:38 EST
drumkv1-0.1.0-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.