Bug 870195 - anaconda manual partitioning partitions can be in more than one entry at a time and having different or the same mount point
anaconda manual partitioning partitions can be in more than one entry at a ti...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 15:03 EDT by Reartes Guillermo
Modified: 2014-02-05 07:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 07:43:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot, showing two /a (75.12 KB, application/octet-stream)
2012-10-25 15:09 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-25 15:03:43 EDT
Description of problem:

It possible to make the UI show a partition in more than one entry, even leading to a partition having two different or same mount points. 

Version-Release number of selected component (if applicable):
F18b TC6

How reproducible:
always

Steps to Reproduce:

0. enter MANUAL PARTITIONING
1. expand the OTHER tree, select a partition. 
2. expand 'CUSTOMIZE' tree, change its type to EXT4 and APPLY.
3. expand the 'NEW FEDORA...' tree (the same partition is already selected)
4. set its MOUNT POINT to /a and change its type to EXT3 and APPLY
5. set its MOUNT POINT to / and APPLY
 
Actual results:
It is possible to have two / entries pointing to the same partition

Expected results:
each partition should have only one entry (or mount point / function)

Additional info:
tried with ntfs basic, ntfs dynamic, swap and a /boot showing in the UNKNOWN tree.
Comment 1 Reartes Guillermo 2012-10-25 15:09:04 EDT
Created attachment 633507 [details]
screenshot, showing two /a
Comment 2 Reartes Guillermo 2012-12-10 19:17:26 EST
I tried again with smoke5 (anaconda 18.37) and i was unable to reproduce the issue. So it looks like this bug-report can be closed safely.

Please close this bug-report.
Comment 3 Fedora End Of Life 2013-12-21 04:12:07 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2014-02-05 07:43:28 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.