Bug 870248 - Volumes for thin provisioning pools are not monitored on activation
Summary: Volumes for thin provisioning pools are not monitored on activation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Peter Rajnoha
QA Contact: Cluster QE
URL:
Whiteboard:
: 883629 (view as bug list)
Depends On: 805420
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-25 22:54 UTC by Corey Marthaler
Modified: 2013-02-21 08:14 UTC (History)
14 users (show)

Fixed In Version: lvm2-2.02.98-2.el6
Doc Type: Bug Fix
Doc Text:
Cause: A missing dependency on the device-mapper-persistent-data package caused problems and thin pool devices were not being monitored on activation. Consequence: Unmonitored pools cannot grow in size, when they overfill the configured threshold. Fix: Code path for enabling monitoring of thin pool has been fixed and the missing package dependency added. Result: When monitoring for thin pool is configured, dmeventd is running and watching for pool overfill.
Clone Of: 805420
Environment:
Last Closed: 2013-02-21 08:14:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0501 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2013-02-20 21:30:45 UTC

Comment 1 Peter Rajnoha 2012-10-26 08:05:55 UTC
(In reply to comment #0)
> It's RHEL6.4 and thin provisioning is now fully supported, so where's our
> device-mapper-persistent-data dependency?
> 
> 
> Removing thinpool snapper_thinp/to_pool_convert
>   /usr/sbin/thin_check: execvp failed: No such file or directory
>   WARNING: Integrity check of metadata for thin pool
> snapper_thinp/to_pool_convert failed.

I'll include that in next 6.4 build... Thanks for the report!

Comment 3 Alasdair Kergon 2012-12-05 11:42:38 UTC
*** Bug 883629 has been marked as a duplicate of this bug. ***

Comment 4 Corey Marthaler 2013-01-03 00:04:51 UTC
Marking verified in the latest rpms.

[root@taft-01 ~]# rpm -qR lvm2-2.02.98-6.el6 | grep device-mapper-persistent-data
device-mapper-persistent-data >= 0.1.4

Comment 6 errata-xmlrpc 2013-02-21 08:14:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html


Note You need to log in before you can comment on or make changes to this bug.