Bug 870315 - 3.0 VDSM: error in upgrade of 4.9-113-4 to 4.9.6-39
3.0 VDSM: error in upgrade of 4.9-113-4 to 4.9.6-39
Status: CLOSED DUPLICATE of bug 870079
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
All Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Alon Bar-Lev
Haim
infra
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 03:11 EDT by Pavel Stehlik
Modified: 2014-01-12 19:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-28 05:49:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bootstrap-log (14.17 KB, text/x-log)
2012-10-26 03:11 EDT, Pavel Stehlik
no flags Details

  None (edit)
Description Pavel Stehlik 2012-10-26 03:11:41 EDT
Created attachment 633682 [details]
bootstrap-log

Description of problem:
 See https://bugzilla.redhat.com/show_bug.cgi?id=866533 which is BZ for vdsm-4.9.6. Yum updates only vdsm, not vdsm-cli.
 In RHEVM:
 - put RHEL host with vdsm..113.4 in to maintenance, then click reinstall.

From log:
 Mon, 17 Dec 2012 08:01:20 DEBUG    Install/Update VDS packages ...
Mon, 17 Dec 2012 08:01:20 DEBUG    Install VDS packages ... ('qemu-kvm', 'qemu-kvm-tools', 'vdsm', 'vdsm-cli', 'libjpeg', 'spice-server', 'pixman', 'seabios', 'qemu-img', 'fence-agents', 'libselinux-python')
Mon, 17 Dec 2012 08:01:20 DEBUG    Update VDS packages ...  ['qemu-kvm', 'qemu-kvm-tools', 'qemu-img']
Mon, 17 Dec 2012 08:01:20 DEBUG    Installing vdsm 1
Mon, 17 Dec 2012 08:01:20 DEBUG    ['/usr/bin/yum', '-y', 'update', 'vdsm']




Version-Release number of selected component (if applicable):
vdsm-bootstrap-4.9-113.4.el6_3.x86_64  with 113.3 same

How reproducible:
100%

Steps to Reproduce:
1. have RHEL host in RHEVM, put it in maintenance
2. in General subtab click 'reinstall' link.
3.
  
Actual results:
Transaction Check Error:
  file /usr/share/vdsm/dumpStorageTable.py from install of vdsm-4.9.6-39.0.el6_3.x86_64 conflicts with file from package vdsm-cli-4.9-113.4.el6_3.x86_64
  file /usr/share/vdsm/dumpStorageTable.pyc from install of vdsm-4.9.6-39.0.el6_3.x86_64 conflicts with file from package vdsm-cli-4.9-113.4.el6_3.x86_64
  file /usr/share/vdsm/dumpStorageTable.pyo from install of vdsm-4.9.6-39.0.el6_3.x86_64 conflicts with file from package vdsm-cli-4.9-113.4.el6_3.x86_64



Expected results:
vdsm-cli-4.9.6-x  will be installed

Additional info:
Full log att.
Comment 1 Itamar Heim 2012-10-26 03:20:59 EDT
i believe same solution as for bug 866533
Comment 3 Alon Bar-Lev 2012-10-26 12:37:29 EDT
Dup of bug#870079.
Comment 4 Barak 2012-10-28 05:49:31 EDT

*** This bug has been marked as a duplicate of bug 870079 ***

Note You need to log in before you can comment on or make changes to this bug.