Bug 870317 - grub2-efi: it failed to switch into *EDIT* mode on uefi machine
grub2-efi: it failed to switch into *EDIT* mode on uefi machine
Status: CLOSED DUPLICATE of bug 859632
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
18
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 03:16 EDT by Zhouping Liu
Modified: 2014-01-12 19:02 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-26 10:03:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/boot/efi/EFI/fedora/grub.cfg (7.17 KB, text/plain)
2012-10-29 03:57 EDT, Zhouping Liu
no flags Details

  None (edit)
Description Zhouping Liu 2012-10-26 03:16:28 EDT
Description of problem:
when booting process step on grub2 screen, the grub can allow us to choose which kernel you use, and edit the kernel boot parameters if need.
but it failed when I enter 'e' character to try to change some info.
the screen does not contain any words, and it can't return back to the grub menu screen using enter 'Esc' button. the system didn't have any response, what I only can do is to enter 'Ctrl+Alt+Delete' to reboot.

Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -qa | grep grub
grub2-tools-2.00-9.fc18.x86_64
grub2-efi-2.00-9.fc18.x86_64
grubby-8.20-1.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. get a uefi machine
2. install fedora18 with Desktop
3. change the kernel parameter during booting in grub menu
  
Actual results:
can't switch into grub EDIT mode

Expected results:
no such above issue
Comment 1 Mads Kiilerich 2012-10-26 10:03:59 EDT
Please report exactly which image you are installing - especially when f18 haven't been installed yet.

The issue should be solved in recent updates. Please update and reopen if you see the same on a fully updated system.
Comment 2 Zhouping Liu 2012-10-29 03:56:27 EDT
(In reply to comment #1)
> Please report exactly which image you are installing - especially when f18
> haven't been installed yet.

I don't understand the 'image' what you said here, but I think the issues still exist after I invoke 'yum update', and I installed Fedora 18 using the latest distro, not updated from Fedora17.

I will attach /boot/efi/EFI/fedora/grub.cfg file, let me know if you need other info, also correct me if I'm wrong.

Thanks,
Zhouping
Comment 3 Zhouping Liu 2012-10-29 03:57:31 EDT
Created attachment 634905 [details]
/boot/efi/EFI/fedora/grub.cfg
Comment 4 Mads Kiilerich 2012-10-29 05:48:39 EDT
It is not clear to me how the system was installed, but you do apparently not have the latest f18 updates.
Comment 5 Lingzhu Xiang 2012-12-07 01:37:52 EST
I had close look to Zhouping's machine. I believe this is the same issue as bug 859632.

*** This bug has been marked as a duplicate of bug 859632 ***

Note You need to log in before you can comment on or make changes to this bug.