Bug 870319 - abiword has double-encoded utf strings in Norwegian strings in gui elements
abiword has double-encoded utf strings in Norwegian strings in gui elements
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 03:30 EDT by Ingvar Hagelund
Modified: 2013-11-23 14:36 EST (History)
3 users (show)

See Also:
Fixed In Version: libgsf-1.14.28-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 14:36:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of abiword with broken Norwegian UTF8 characters (59.23 KB, image/png)
2012-10-26 03:30 EDT, Ingvar Hagelund
no flags Details
Fixes double encoding in nb_NO strings. (81.98 KB, patch)
2013-02-04 10:14 EST, Ingvar Hagelund
no flags Details | Diff

  None (edit)
Description Ingvar Hagelund 2012-10-26 03:30:18 EDT
Created attachment 633686 [details]
Screenshot of abiword with broken Norwegian UTF8 characters

Description of problem:
abiword has wrongly coded, possible double-encoded utf, Norwegian strings in gui elements

Version-Release number of selected component (if applicable):
abiword-2.8.6-18

How reproducible:
Always

Steps to Reproduce:
1. Start abiword with Norwegian locales, like this: LANG=nb_NO.UTF-8 abiword
2. Watch something that looks like double-encoded characters everywhere special Norwegian characters are used in GTK elements like buttons or menues

  
Actual results:
Strings with special Norwegian characters are displayed wrongly, possible because of double-encoded UTF8. Example: The word "språk" (language) is displayed as "sprÃ¥k"

Expected results:
special Norwegian characters æøå ÆØÅ displayed as such.

Additional info:
See attached screenshot for more examples.
Comment 1 Ingvar Hagelund 2013-02-04 09:16:16 EST
This is still a bug in fedora 18. Updating version.

Ingvar
Comment 2 Ingvar Hagelund 2013-02-04 10:13:22 EST
Seems this is simply an error in the coding of the xml file. Its contents should be iso8859-1, but the file is encoded as utf8. A trivial conversion with iconv fails, so I have converted the file manually. I have made a patch that builds and gives the expected result.

Ingvar
Comment 3 Ingvar Hagelund 2013-02-04 10:14:29 EST
Created attachment 692803 [details]
Fixes double encoding in nb_NO strings.
Comment 4 Ingvar Hagelund 2013-02-04 10:45:13 EST
Co-reported to upstream:

http://bugzilla.abisource.com/show_bug.cgi?id=13474
Comment 5 Peter Robinson 2013-11-10 17:47:36 EST
Can you test this against abiword 3, currently in Fedora 20
Comment 6 Fedora Update System 2013-11-18 15:00:29 EST
libgsf-1.14.28-1.fc19,abiword-3.0.0-4.fc19,sugar-write-94-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libgsf-1.14.28-1.fc19,abiword-3.0.0-4.fc19,sugar-write-94-1.fc19
Comment 7 Fedora Update System 2013-11-19 00:29:34 EST
Package libgsf-1.14.28-1.fc19, abiword-3.0.0-4.fc19, sugar-write-94-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libgsf-1.14.28-1.fc19 abiword-3.0.0-4.fc19 sugar-write-94-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21665/libgsf-1.14.28-1.fc19,abiword-3.0.0-4.fc19,sugar-write-94-1.fc19
then log in and leave karma (feedback).
Comment 8 Ingvar Hagelund 2013-11-19 05:02:24 EST
I can confirm that this is fixed in abiword-3.0.0-4.fc19

Ingvar
Comment 9 Fedora Update System 2013-11-23 14:36:57 EST
libgsf-1.14.28-1.fc19, abiword-3.0.0-4.fc19, sugar-write-94-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.