Bug 870330 - Cache records in memory
Cache records in memory
Status: CLOSED DUPLICATE of bug 1159621
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.6.0
Assigned To: Liran Zelkha
bugs@ovirt.org
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 03:54 EDT by Laszlo Hornyak
Modified: 2016-02-10 14:31 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 04:41:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21952 None None None Never

  None (edit)
Description Laszlo Hornyak 2012-10-26 03:54:31 EDT
Description of problem:

Some database operations could be eliminated by keeping a cache for the records. This could shorten the engine response times and drop the database load.

For example VDS static records change very rarely, but they are used almost all the time by the engine, the number of such records rarely exceed some hundred, which is still a very small amount of space in the memory.
Comment 1 Itamar Heim 2012-10-28 04:46:44 EDT
we should not add caching until we solve jboss clustering aspects.
the idea of not having caches in engine (yes, we have a few culprits) is to allow distributing/partitioning the load of the engine to multiple processes.
Comment 2 Laszlo Hornyak 2012-10-29 03:06:52 EDT
I know there are some static Map's to cache data. Probably replacing those to any real cache implementations would help to solve the clustering problems. Probably any cache implementation can work on distributed mode.
Comment 3 Itamar Heim 2013-05-05 02:28:17 EDT
isn't the infra for this now done with the infinispan patches to close this?
Comment 4 Laszlo Hornyak 2013-05-05 05:39:59 EDT
(In reply to comment #3)
> isn't the infra for this now done with the infinispan patches to close this?

Last time I have seen the cache implementation it was not caching results from DAO's, but I will check again.
Comment 5 Laszlo Hornyak 2013-05-06 03:34:52 EDT
(In reply to comment #3)
> isn't the infra for this now done with the infinispan patches to close this?

Checked again on latest master and cache is not used for cahcing Db records.
Comment 7 Eli Mesika 2013-11-11 16:16:48 EST
http://gerrit.ovirt.org/#/c/20894/ seems related to this BZ
Liran please handle
Comment 8 Liran Zelkha 2013-11-12 01:27:27 EST
Please see gerrit change http://gerrit.ovirt.org/#/c/20894/
Comment 9 Sandro Bonazzola 2014-03-04 04:28:25 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 11 Oved Ourfali 2015-08-11 04:41:31 EDT

*** This bug has been marked as a duplicate of bug 1159621 ***

Note You need to log in before you can comment on or make changes to this bug.