Bug 870388 - Network kickstart install with virt-install fails at partitioning step
Network kickstart install with virt-install fails at partitioning step
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 06:54 EDT by Paul Maunders
Modified: 2013-01-09 21:25 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-18.19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-27 15:58:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example anaconda.log (946 bytes, application/octet-stream)
2012-10-26 06:55 EDT, Paul Maunders
no flags Details
packaging.log (135 bytes, application/octet-stream)
2012-10-26 06:56 EDT, Paul Maunders
no flags Details
program.log (919 bytes, application/octet-stream)
2012-10-26 06:57 EDT, Paul Maunders
no flags Details
storage.log (4.96 KB, application/octet-stream)
2012-10-26 06:58 EDT, Paul Maunders
no flags Details
syslog (60.48 KB, application/octet-stream)
2012-10-26 06:58 EDT, Paul Maunders
no flags Details

  None (edit)
Description Paul Maunders 2012-10-26 06:54:55 EDT
Description of problem:

Automated installs using virt-install and a HTTP kickstart file fail at / before the partitioning step.  

At first I thought it may be because I am using GUID partition tables, but it appears to fail with or without this.

Version-Release number of selected component (if applicable):

Using Fedora 18 Alpha. 

How reproducible:

Occurs every time I have tried, with or without GUID partition tables (GPT).

Steps to Reproduce:

1. To test with GUID partition tables, run this virt-install command...

    virt-install \
    --name "fedora18-alpha-guest-gpt" \
    --ram 1024 \
    --nographics \
    --os-type=linux \
    --os-variant=rhel6 \
    --location=http://mirror.ox.ac.uk/sites/download.fedora.redhat.com/pub/fedora/linux/releases/test/18-Alpha/Fedora/x86_64/os/ \
    --extra-args="ks=http://fubralimited.github.com/CentOS-KVM-Image-Tools/kickstarts/fedora18-alpha-guest-gpt.cfg text console=tty0 utf8 console=ttyS0,115200" \
    --disk path=/var/lib/libvirt/images/fedora18-alpha-guest-gpt.img,size=10,bus=virtio,format=qcow2
  
or

2. To test without GUID partition tables, run this virt-install command...

    virt-install \
    --name "fedora18-alpha-guest-nogpt" \
    --ram 1024 \
    --nographics \
    --os-type=linux \
    --os-variant=rhel6 \
    --location=http://mirror.ox.ac.uk/sites/download.fedora.redhat.com/pub/fedora/linux/releases/test/18-Alpha/Fedora/x86_64/os/ \
    --extra-args="ks=http://fubralimited.github.com/CentOS-KVM-Image-Tools/kickstarts/fedora18-alpha-guest.cfg text console=tty0 utf8 console=ttyS0,115200" \
    --disk path=/var/lib/libvirt/images/fedora18-alpha-guest-nogpt.img,size=10,bus=virtio,format=qcow2


Actual results:

The installer stops after running the %pre scripts, some errors appear in storage.log and program.log

Storage.log - 

INFO anaconda: No FCoE EDD info found: No FCoE boot disk information is found in EDD!

Program.log - 

ERR program: FATAL: Module scsi_wait_scan not found.

Syslog - 

ERR systemd-udevd: failed to execute '/usr/lib/udev/socket:/org/kernel/dm/multipath_event' 'socket:/org/kernel/dm/multipath_event': No such file or directory

Expected results:

Installer should have progressed to the drive partitioning steps.

Additional info:

I'll submit attachments separately.
Comment 1 Paul Maunders 2012-10-26 06:55:59 EDT
Created attachment 633792 [details]
Example anaconda.log
Comment 2 Paul Maunders 2012-10-26 06:56:47 EDT
Created attachment 633793 [details]
packaging.log
Comment 3 Paul Maunders 2012-10-26 06:57:38 EDT
Created attachment 633794 [details]
program.log
Comment 4 Paul Maunders 2012-10-26 06:58:02 EDT
Created attachment 633795 [details]
storage.log
Comment 5 Paul Maunders 2012-10-26 06:58:35 EDT
Created attachment 633796 [details]
syslog
Comment 6 Jesse Keating 2012-10-26 14:48:16 EDT
Just looking at first, you are passing two console= blocks, is that on purpose?  I don't think it has any impact, just looks odd. 

I also notice that the kickstart file is pointing to F17 repositories, not F18.  Again I don't /think/ that will cause a problem at the stage you're seeing, but likely not the desired results.  Not only that, you have both url and repo pointing to the same location.

Lastly you're using anaconda 18.6.8, which is quite old.  We're pushing 18.21 into the Beta.  It would be useful to test with something of that age.

You could grab boot content from http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC6/Fedora/x86_64/os/

Can you try without a %pre statement at all?  Even the empty one could have some impact.
Comment 7 Paul Maunders 2012-10-27 10:21:18 EDT
OK I updated the Alpha kickstarts and virt-install to...

- Remove the two console blocks
- Fix the kickstart to point at F18 repos
- Remove the superfluous repo definition

    virt-install \
    --name "fedora18-alpha-guest" \
    --ram 1024 \
    --nographics \
    --os-type=linux \
    --os-variant=rhel6 \
    --location=http://mirror.ox.ac.uk/sites/download.fedora.redhat.com/pub/fedora/linux/releases/test/18-Alpha/Fedora/x86_64/os/ \
    --extra-args="ks=http://fubralimited.github.com/CentOS-KVM-Image-Tools/kickstarts/fedora18-alpha-guest.cfg text console=ttyS0,115200" \
    --disk path=/var/lib/libvirt/images/fedora18-alpha-guest.img,size=10,bus=virtio,format=qcow2

That's still not working...

However, I've also tried the F18 beta...

- Using the download url you specified
- Removing the %pre section completely

    virt-install \
    --name "fedora18-beta-guest" \
    --ram 1024 \
    --nographics \
    --os-type=linux \
    --os-variant=rhel6 \
    --location=http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC6/Fedora/x86_64/os/ \
    --extra-args="ks=http://fubralimited.github.com/CentOS-KVM-Image-Tools/kickstarts/fedora18-beta-guest.cfg text console=ttyS0,115200" \
    --disk path=/var/lib/libvirt/images/fedora18-beta-guest.img,size=10,bus=virtio,format=qcow2

And that does install, but after it restarts I don't seem to be able to connect via the console...

Guest installation complete... restarting guest.
Connected to domain fedora18-beta-guest
Escape character is ^]

It just sits there...
Comment 8 Jesse Keating 2012-10-27 15:58:04 EDT
Hrm, not sure why it would sit there after reboot.  It should have setup the boot loader to use the serial console.

However it sounds like the block at partitioning is fixed, so this current bug is fine.

I'd file a new bug, including all your log files for the case where reboot isn't successful.

Note You need to log in before you can comment on or make changes to this bug.