Bug 870430 - Unable to add mount points manually
Unable to add mount points manually
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
: 875404 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 09:11 EDT by David Levine
Modified: 2014-02-05 17:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 17:51:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda error when attempting to add mount point (560.07 KB, text/plain)
2012-10-26 16:30 EDT, David Levine
no flags Details

  None (edit)
Description David Levine 2012-10-26 09:11:12 EDT
Description of problem:
  Attempts to manually add mount points, including /, fail.

Version-Release number of selected component (if applicable):
  [image size: 743440384] Sep 12 21:34 Fedora-18-Alpha-x86_64-Live-XFCE.iso

How reproducible:
  On system that never had Fedora (or any Linux) installation:
  Boot live image.  Use fdisk to create ext4 partitions and make
  the filesystems.  Set desired / partition as bootable.
  Select Install to Hard Disk, then follow steps below.

Steps to Reproduce:
1. Select INSTALLATION DESTINATION under STORAGE.
2. Select the one local disk (ATA Hitachi HTS72505).  Click CONTINUE.
3. On Installation Options popup,
   select "Let me review & customize the partitioning of the disks anyway".
   Click Continue.
4. Expand "Unknown".
5. Select one of the ext4 partitions.
6. Click "+".
7. Enter "/" for "Mount Point".  (Entering "Desired Capacity" or not seems to have no effect.)
8. Click "Add mount point."
9. Click "FINISH PARTITIONING."  (There is no indication of success or failure.)
  
Actual results:
Return to INSTALLATION SUMMARY screen, there is still the warning icon next to INSTALLATION DESTINATION.  Following that, the error message is "You have not defined a root partition (/), which is required for installation of Fedora to continue.  You have not created a bootable partition."

Expected results:
Creation of mount point.  Same happens with attempted creation of /home.

Additional info:
After installing Fedora 17 (without any issues), same thing happens, except the ext4 partitions are listed under "Fedora Linux 17 for x86_64" instead of "Unknown".
Comment 1 Jesse Keating 2012-10-26 14:50:58 EDT
The alpha is quite old now.  Can you try one of the latest Beta test composes?  http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC6/
Comment 2 David Levine 2012-10-26 16:30:37 EDT
Created attachment 634035 [details]
anaconda error when attempting to add mount point
Comment 3 David Levine 2012-10-26 16:33:05 EDT
The problem is still present in this beta:
    Oct 19 22:23 Fedora-18-Beta-TC6-x86_64-Live-XFCE.iso

though the behavior is different than the alpha.

On the MANUAL PARTITIONING screen, I see three groups in the left hand pane:

+ New Fedora 18 Installation
- Fedora Linux 17 for x86_64
    DATA
      Sda7
      Home
    SYSTEM
      Root
      Swap
+ Unknown

Sda7 is ext4 but empty (75 GB), so I want to use it for /.  And I want to mount
 Home on /home.  So I do the following:

1) Click on Sda7, then click on -, then confirm deletion from Fedora Linux 17.
2) Expand "New Fedora 18 Installation"
3) Click +, enter / for the mount point, click Add Mount Point (IIRC)

Then I get "An unknown error has occurred".  I tried clicking "Report Bug" but
that causes other problems.  I attached the bug report to this one.

My partitions are out of order (partition 3 (of 7) occupies the highest sectors
), that's the only thing I expect is odd in my setup.  Other than me trying to manually partition.
Comment 4 David Levine 2012-10-26 16:38:28 EDT
I should mention that I'm guessing at how I'm supposed to use the + and - buttons to set up my mount points.  I'm comfortable with the way mount points were set up through Fedora 17, is there some different with 18 that I'm missing?
Comment 5 David Lehman 2012-11-08 20:16:33 EST
If you want to use sda7 as your root device, here's what you do:

 1) select it
 2) set the mountpoint (near the top on the right side)
 3) click the "Customize" expander on right side of screen
 4) choose a filesystem type
 5) activate the "Reformat" checkbutton
 6) click on "Apply Changes" button


+ means "add a new device/filesystem"
- means "remove the selected device"
Comment 6 David Levine 2012-11-11 10:33:49 EST
Alright, that allowed me to install TC8.

But, I am no longer able to boot my existing Fedora 17 installation (on /dev/sda5):

  Dependency failed. Aborted start of /mnt/sda7
  Dependency failed. Aborted start of Relabel all filesystems, if necessary
  Dependency failed. Aborted start of Mark the need to relabel after reboot

and it gives me the choice of entering the root password for maintenance or Control-D to continue.  I tried Control-D but no progress.

I have not tried to boot Fedora 18 after the install.  Should I, or will that wreck my chance of ever being able to boot Fedora 17 again?

Or, what can I do to disable the relabel after reboot attempt?
Comment 7 David Levine 2012-11-11 11:07:55 EST
Never mind:  I was able to boot my Fedora 17 by removing the /mnt/sda7 mountpoint from its fstab.  Apparently the F18 install changed the UUID on that partition.

And F18 TC8 boots!

I'm not sure if I'm supposed to close this bug.  I believe it can be closed now.
Comment 8 David Lehman 2012-11-12 16:01:18 EST
*** Bug 875404 has been marked as a duplicate of this bug. ***
Comment 9 Fedora End Of Life 2013-12-21 10:09:46 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2014-02-05 17:51:04 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.