Bug 870528 - [abrt]: [484461.345228] WARNING: at net/wireless/mlme.c:490 cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]()
[abrt]: [484461.345228] WARNING: at net/wireless/mlme.c:490 cfg80211_mlme_dis...
Status: CLOSED DUPLICATE of bug 862168
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:527f7fb1177c4c42f5ee1112cea...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 14:31 EDT by Peter Portante
Modified: 2012-11-01 06:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 06:01:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Portante 2012-10-26 14:31:11 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/vmlinuz-3.4.11-1.fc16.x86_64 root=/dev/mapper/vg_frodo-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_frodo/lv_root KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks.uuid=luks-477b3b96-9330-4763-8f78-d689fb00bfba rd.lvm.lv=vg_frodo/lv_swap LANG=en_US.UTF-8

backtrace:
:[484461.345228] WARNING: at net/wireless/mlme.c:490 cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]()
:[484461.345230] Hardware name: 4243B37
:[484461.345231] Modules linked in: ipheth tcp_lp fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge 8021q garp stp llc fcoe lockd libfcoe libfc scsi_transport_fc scsi_tgt be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm vhost_net thinkpad_acpi btusb bluetooth arc4 iwlwifi snd_timer macvtap macvlan tun snd iTCO_wdt e1000e uvcvideo iTCO_vendor_support soundcore mac80211 cfg80211 videobuf2_core videodev media videobuf2_vmalloc videobuf2_memops kvm_intel kvm tpm_tis tpm tpm_bios snd_page_alloc rfkill uinput binfmt_misc joydev coretemp i2c_i801 sunrpc microcod
:e xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel firewire_ohci firewire_core sdhci_pci sdhci crc_itu_t mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[484461.345289] Pid: 1344, comm: wpa_supplicant Tainted: G        W    3.4.11-1.fc16.x86_64 #1
:[484461.345291] Call Trace:
:[484461.345298]  [<ffffffff8105810f>] warn_slowpath_common+0x7f/0xc0
:[484461.345301]  [<ffffffff8105816a>] warn_slowpath_null+0x1a/0x20
:[484461.345308]  [<ffffffffa02d0a74>] cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]
:[484461.345313]  [<ffffffff815fbb2d>] ? mutex_lock+0x1d/0x50
:[484461.345319]  [<ffffffffa02c278e>] nl80211_disassociate+0xbe/0xf0 [cfg80211]
:[484461.345325]  [<ffffffff8151943a>] genl_rcv_msg+0x21a/0x2b0
:[484461.345328]  [<ffffffff81519220>] ? genl_rcv+0x40/0x40
:[484461.345330]  [<ffffffff81518be9>] netlink_rcv_skb+0xa9/0xd0
:[484461.345332]  [<ffffffff81519205>] genl_rcv+0x25/0x40
:[484461.345335]  [<ffffffff815185be>] netlink_unicast+0x1ae/0x1f0
:[484461.345337]  [<ffffffff815188fe>] netlink_sendmsg+0x2fe/0x360
:[484461.345341]  [<ffffffff814d7c27>] sock_sendmsg+0x117/0x130
:[484461.345345]  [<ffffffff812a8078>] ? blk_finish_plug+0x18/0x50
:[484461.345349]  [<ffffffff814da45a>] ? move_addr_to_kernel+0x5a/0xa0
:[484461.345352]  [<ffffffff814e6186>] ? verify_iovec+0x56/0xd0
:[484461.345354]  [<ffffffff814d9546>] __sys_sendmsg+0x396/0x3b0
:[484461.345358]  [<ffffffff8118328a>] ? do_sync_write+0xda/0x120
:[484461.345362]  [<ffffffff8119cd4c>] ? destroy_inode+0x3c/0x70
:[484461.345365]  [<ffffffff811c06a4>] ? fsnotify+0x1e4/0x290
:[484461.345368]  [<ffffffff814db399>] sys_sendmsg+0x49/0x90
:[484461.345372]  [<ffffffff81605ee9>] system_call_fastpath+0x16/0x1b
Comment 1 Stanislaw Gruszka 2012-10-28 06:22:00 EDT
3.4.11 is ancient kernel. Can you reproduce the problem on kernel updated to 3.6.0 or later (i.e. http://koji.fedoraproject.org/koji/buildinfo?buildID=360540) ?
Comment 2 Stanislaw Gruszka 2012-11-01 06:01:19 EDT
Actually this should be fixed on 3.6.3 or latter.

*** This bug has been marked as a duplicate of bug 862168 ***

Note You need to log in before you can comment on or make changes to this bug.