Bug 870548 - Firefox armhf runs at small fraction of speed of Debian equivilent
Firefox armhf runs at small fraction of speed of Debian equivilent
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
18
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Martin Stransky
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-10-26 15:57 EDT by shawnlandden
Modified: 2013-01-09 05:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 05:22:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shawnlandden 2012-10-26 15:57:35 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
run the v8 benchmark on armhf firefox

http://v8.googlecode.com/svn/data/benchmarks/v7/run.html

Fedora: 26
Debian experimental (ff 16): 366

Expected results:

similar results on same hardware and same version of firefox

Additional info:

this is because fedora uses --disable-methodjit and --disable-tracejit, the JIT works on all armhf hardware, and should be enabled, debian only disables the jit for armel (armv4t+)
Comment 1 Martin Stransky 2012-10-31 08:29:07 EDT
I wonder how is this bug related to security?
Comment 2 Tomas Hoger 2012-10-31 09:10:49 EDT
(In reply to comment #1)
> I wonder how is this bug related to security?

You made it non-public / security when you assigned it to yourself.  I'm reverting those changes.
Comment 3 Peter Robinson 2013-01-09 05:22:14 EST
This is fixed in xulrunner-17.0.1-3 and later for F-17+ for armv7 platforms

Note You need to log in before you can comment on or make changes to this bug.