Bug 870552 - anaconda nfs install entering a wrong path (on a valid nfs server) results in a long pause, BUT with a gray screen
Summary: anaconda nfs install entering a wrong path (on a valid nfs server) results in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-26 20:18 UTC by Reartes Guillermo
Modified: 2013-01-10 02:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-23 06:08:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Reartes Guillermo 2012-10-26 20:18:12 UTC
Description of problem:

When installing over NFS, if one enters the path wrong, one must wait a timeout (that is probably ok), but during such timeout, instead of the main hub one has to wait in presence of a gray screen. This defeats the main hub approach.

Version-Release number of selected component (if applicable):
F18b TC6

How reproducible:
always

Steps to Reproduce:
1. go to INSTALLATION SOURCE and select NFS
2. 192.168.0.80:/var/ftp/puX
3. return to the main hub
  
Actual results:
Anaconda does not return to the main hub, instead a big pause with a gray screen must be waited. After such pause (a couple of minutes) the main hub is shown, and the source was not configured (that is OK, since the path was wrong).

Expected results:
return to the main hub intermediately and do the waiting in the background. Such time can be spent in other parts of the hub.

Additional info:
Normally 192.168.0.80:/var/ftp/pub does work and does not experience any delay nor issue. I was able to install properly (i only tested minimal).


Additional info #2:
I tried the bg parameter but in such case the gray screen seems to be 'permanent', or at least long. +5 minutes and it did not return to the main hub.

Comment 1 Jesse Keating 2012-10-29 19:22:27 UTC
I was only able to reproduce it by pointing at a live server that was /not/ setup for NFS.  My valid NFS server quickly returned an error if I gave it an invalid pass.

Patch posted to do this work in the background.

Comment 2 Fedora Update System 2012-11-01 02:51:50 UTC
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18

Comment 3 Fedora Update System 2012-11-01 18:27:37 UTC
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2012-11-02 04:06:22 UTC
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18

Comment 5 Fedora Update System 2012-11-03 01:05:49 UTC
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18

Comment 6 Fedora Update System 2012-11-06 01:40:58 UTC
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18

Comment 7 Fedora Update System 2012-11-07 02:13:02 UTC
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18

Comment 8 Adam Williamson 2012-11-23 06:08:37 UTC
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(I noticed while testing the NFS regressions in RC1 this appears to be fixed, attempts to contact NFS server happen in the background).


Note You need to log in before you can comment on or make changes to this bug.