Bug 870556 - install produces AttributeError: 'YumPayload' object has no attribute 'storage'
Summary: install produces AttributeError: 'YumPayload' object has no attribute 'storage'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: arm
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F18-accepted, F18FinalFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2012-10-26 20:31 UTC by D. Marlin
Modified: 2012-11-23 06:09 UTC (History)
4 users (show)

Fixed In Version: anaconda-18.22-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-23 06:09:03 UTC
Type: Bug


Attachments (Terms of Use)
F18 test kickstart config for Calxeda Highbank (2.10 KB, application/octet-stream)
2012-10-26 20:31 UTC, D. Marlin
no flags Details

Description D. Marlin 2012-10-26 20:31:44 UTC
Created attachment 634036 [details]
F18 test kickstart config for Calxeda Highbank

Description of problem:

When performing an F18 kickstart install, I receive a backtrace (see results):

  AttributeError: 'YumPayload' object has no attribute 'storage'


Version-Release number of selected component (if applicable):

  anaconda-18.19-1.fc18


How reproducible:

  always


Steps to Reproduce:
1. Start a PXE-boot, kickstart install
2. Select the only disk drive (sda) and use all space
3. After Starting package installation, backtrace occurs
  

Actual results:

Starting package installation process
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/install.py", line 117, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1191, in preInstall
    self.checkSoftwareSelection()
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1112, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1098, in _applyYumSelections
    self.selectKernelPackage()
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1144, in selectKernelPackage
    kernels = self.kernelPackages
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 657, in kernelPackages
    if self.storage.platform.armMachine is not None:
AttributeError: 'YumPayload' object has no attribute 'storage'


Expected results:

  installation completes


Additional info:

  The kickstart config used is attached for reference.

Comment 1 Chris Lumens 2012-10-29 14:54:56 UTC
Does updates=http://clumens.fedorapeople.org/870556.img fix this?

Comment 2 D. Marlin 2012-10-29 17:37:43 UTC
The update provided gets past this point in the installation before failing (due to a different issue).  I believe the update provided resolves the initial problem.  I will open a new BZ for the new issue.

Comment 3 Fedora Update System 2012-11-01 02:52:02 UTC
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18

Comment 4 Fedora Update System 2012-11-01 18:27:55 UTC
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-11-02 04:06:34 UTC
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18

Comment 6 Fedora Update System 2012-11-03 01:06:04 UTC
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18

Comment 7 Fedora Update System 2012-11-06 01:41:12 UTC
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18

Comment 8 Fedora Update System 2012-11-07 02:13:18 UTC
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18

Comment 9 Adam Williamson 2012-11-23 06:09:03 UTC
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(ref comment #2)


Note You need to log in before you can comment on or make changes to this bug.