Bug 870612 - lpq.cups (version 1.5.4-2) cannot get printers list and default printer from old cups server (cups-1.1.23-15.4)
Summary: lpq.cups (version 1.5.4-2) cannot get printers list and default printer from ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 17
Hardware: i386
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-27 09:55 UTC by Maurizio Paolini
Modified: 2012-11-23 07:13 UTC (History)
2 users (show)

Fixed In Version: cups-1.5.4-9.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-19 02:22:10 UTC
Type: Bug


Attachments (Terms of Use)
this is the patch that apparently introduces the problem (2.77 KB, patch)
2012-10-27 09:55 UTC, Maurizio Paolini
no flags Details | Diff

Description Maurizio Paolini 2012-10-27 09:55:30 UTC
Created attachment 634144 [details]
this is the patch that apparently introduces the problem

Description of problem:

A client with Fedora 17, cups-1.5.4-2 cannot get default printer with lpq, nor get information with lpq -P<printer-name> from a cups server version 
1.1.23-15.4.
Some applications (okular, evince) have problems: okular does not show the
network printer in the printing menu, evince does not allow to select the
network printer.


Version-Release number of selected component (if applicable):

Fedora 17, cups-1.5.4-2 (client side), Fedora core 4, cups 1.1.23-15.4
(server side)

How reproducible:

lpq on the client tells that it cannot get the default printer.
Also "lpq -Plp" gives

lpq: Unknown destination "lp".

(lp is the actual network printer name)


Additional info:

It seems that the culprit is patch cups-cups-get-classes.patch in the
source rpm (listed as Patch22 in cups.spec) since building an rpm package
without that patch solves the problem.
Adding said patch as attachment.

Comment 1 Tim Waugh 2012-10-29 11:43:52 UTC
Seeing as that patch was intended to add compatibility with 1.1.x servers, the best course of action is to remove it altogether.

Thanks for the report, and for narrowing down where the problem is.

Comment 2 Maurizio Paolini 2012-10-29 13:28:16 UTC
Removing the patch would certainly solve the problem for us... however our
server configuration is very basic:
- one print queue (named "lp")
- no class

(In reply to comment #1)
> Seeing as that patch was intended to add compatibility with 1.1.x servers,
> the best course of action is to remove it altogether.
> 
> Thanks for the report, and for narrowing down where the problem is.

However in principle there might exist more complex environments where the
patch is necessary and does it's job correctly.  I have no idea.

Also, after a very cursory look at the patch I could not understand what
is wrong with it.
Note that "lpstat ..." on the client side *did* work with the patch,
whereas "lpq" (together with applications like okular or evince) did not.

Comment 3 Fedora Update System 2012-10-29 16:25:24 UTC
cups-1.5.4-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-15936/cups-1.5.4-12.fc18

Comment 4 Fedora Update System 2012-10-29 16:47:25 UTC
cups-1.5.4-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-14508/cups-1.5.4-9.fc17

Comment 5 Maurizio Paolini 2012-10-29 17:30:16 UTC
Thank you, the 1.5.4-9.fc17 rpm seems to work fine for me

Comment 6 Fedora Update System 2012-10-29 18:14:49 UTC
Package cups-1.5.4-12.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.5.4-12.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15936/cups-1.5.4-12.fc18
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-11-19 02:22:11 UTC
cups-1.5.4-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-11-23 07:13:04 UTC
cups-1.5.4-14.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.