Bug 870655 - Installation of some third-party RPMs failing with file conflict errors
Summary: Installation of some third-party RPMs failing with file conflict errors
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Packaging Toolset Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-27 17:35 UTC by Michel Alexandre Salim
Modified: 2016-08-14 07:41 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 10:30:47 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Typescript of attempts to install Google Music Manager and VirtualBox via yum and rpm (18.72 KB, text/plain)
2012-10-27 17:35 UTC, Michel Alexandre Salim
no flags Details
VirtualBox repo file, slightly modified for F18 (220 bytes, application/octet-stream)
2012-10-27 17:37 UTC, Michel Alexandre Salim
no flags Details
Google Music Manager repo file (134 bytes, application/octet-stream)
2012-10-27 17:37 UTC, Michel Alexandre Salim
no flags Details

Description Michel Alexandre Salim 2012-10-27 17:35:57 UTC
Created attachment 634291 [details]
Typescript of attempts to install Google Music Manager and VirtualBox via yum and rpm

Description of problem:
VirtualBox and Google Music Manager can no longer be installed on Fedora 18, after working just fine in previous Fedora releases, due to rpm and yum reporting file conflicts.

Version-Release number of selected component (if applicable):
rpm-4.10.1-3.fc18.x86_64
yum-3.4.3-45.fc18.noarch
filesystem-3.1-2.fc18.x86_64
google-musicmanager-beta-1.0.43.6722-0.x86_64
VirtualBox-4.2-4.2.4_81684_fedora17-1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 18
2. Add Google Music Manager and VirtualBox repos
3. yum install google-musicmanager VirtualBox-4.2
  
Actual results:
Fails:
Transaction Check Error:
  file /usr/bin from install of google-musicmanager-beta-1.0.43.6722-0.x86_64 conflicts with file from package filesystem-3.1-2.fc18.x86_64
  file /usr/bin from install of VirtualBox-4.2-4.2.4_81684_fedora17-1.x86_64 conflicts with file from package filesystem-3.1-2.fc18.x86_64
  file /lib/modules from install of VirtualBox-4.2-4.2.4_81684_fedora17-1.x86_64 conflicts with file from package filesystem-3.1-2.fc18.x86_64

More complete logs attached.

Expected results:
The packages should install as before.

Additional info:

Comment 1 Michel Alexandre Salim 2012-10-27 17:37:15 UTC
Created attachment 634292 [details]
VirtualBox repo file, slightly modified for F18

Upstream doesn't support Fedora 18 directly yet, so $releasever had to be set to 18

Comment 2 Michel Alexandre Salim 2012-10-27 17:37:46 UTC
Created attachment 634293 [details]
Google Music Manager repo file

Comment 3 Panu Matilainen 2012-10-29 10:30:47 UTC
This is a packaging bug in both VirtualBox and google-musicmanager: they claim to own /usr/bin directory (which they have no business owning) and the specified permissions differ from those of filesystem package. Rpm < 4.10 just does not notice and report the permission conflict. 

Report to Google and Oracle, they need to fix their packaging.

Comment 4 Juanjo Marin 2012-12-24 20:45:00 UTC
This problem can also be reproduced with google earth

Comment 5 Julian Batliner 2012-12-29 10:56:43 UTC
Issue has been created for Google Earth:
http://code.google.com/p/earth-issues/issues/detail?id=1525

Comment 6 Mario Ganz 2013-05-27 17:34:42 UTC
I have a similar Issue with nixnote on fedora 18. 

(sorry, error is in german)
Datei / aus der Installation von nixnote-1.5-2.x86_64 kollidiert mit der Datei aus dem Paket filesystem-3.1-2.fc18.x86_64
	Datei /usr/bin aus der Installation von nixnote-1.5-2.x86_64 kollidiert mit der Datei aus dem Paket filesystem-3.1-2.fc18.x86_64

http://sourceforge.net/projects/nevernote/files/Current/nixnote-1.5-2.x86_64.rpm/download

Comment 7 Rob Freeman 2013-06-13 11:12:49 UTC
@Mario Ganz - it seems that the nixnote package was ported from a .deb. If we check the output of

  # rpm -qpi nixnote-*.x86_64.rpm
...
(Converted from a deb package by alien version 8.88.)

It seems that either alien doesn't convert properly or the nixnote maintainers need to package properly for Fedora.

Comment 8 John 2016-08-14 07:41:57 UTC
Four fucking years, and google earh rpm for linux still gives this error.

Obviously, you can install with rpm --force, but this is going to be an obstacle for many users. 

Pathetic, unprofessional, pitiful lack of effort from google.


Note You need to log in before you can comment on or make changes to this bug.