Bug 870712 - A very simple MOTIF program fails with "X Error of failed request: BadWindow (invalid Window parameter)"
Summary: A very simple MOTIF program fails with "X Error of failed request: BadWindow...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: motif
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-28 06:58 UTC by Joachim Backes
Modified: 2012-10-29 15:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-29 15:00:20 UTC
Type: Bug


Attachments (Terms of Use)
The testprogram's source (2.73 KB, text/x-csrc)
2012-10-28 06:58 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2012-10-28 06:58:06 UTC
Created attachment 634443 [details]
The testprogram's source

Description of problem:

Compiling (no error!) and starting a very simple MOTIF program on the Gnome3 desktop, but it fails immediately:


Version-Release number of selected component (if applicable):
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  19 (X_DeleteProperty)
  Resource id in failed request:  0x0
  Serial number of failed request:  85
  Current serial number in output stream:  89

Motif software used:

motif-devel-2.3.4-3.fc18.x86_64
motif-2.3.4-3.fc18.x86_64



How reproducible:
alwyays

Steps to Reproduce:
1. Compile link the attached source file by "gcc -lXt -lXm xmhallo.c"
2. ./a.out
3.
  
Actual results:
Version-Release number of selected component (if applicable):
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  19 (X_DeleteProperty)
  Resource id in failed request:  0x0
  Serial number of failed request:  85
  Current serial number in output stream:  89

Expected results:
the window is shown

Additional info:

Comment 1 Joachim Backes 2012-10-28 07:11:37 UTC
Same (bad) results if using MWM as windowmanager instead of gnome-shell.

Comment 2 Thomas Woerner 2012-10-29 15:00:20 UTC
Please use the proper order of the needed libraries:

gcc -lXm -lXt xmhallo.c

Closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.