Bug 870873 - RFE: A translator should be able push po files for non-po file projects
RFE: A translator should be able push po files for non-po file projects
Status: CLOSED DUPLICATE of bug 870876
Product: Zanata
Classification: Community
Component: Component-Persistence (Show other bugs)
development
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 01:05 EDT by Ding-Yi Chen
Modified: 2013-03-03 21:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 02:28:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-10-29 01:05:13 EDT
Description of problem:
Zanata provides "Download as po", however, if translators do download the translation this way and do the off-line translation, they won't be able to push it back if the project does not use po files.

A translator should be able push po files for non-po file projects.


Version-Release number of selected component (if applicable):
Zanata version 2.0.1-SNAPSHOT (20121029-1430

How reproducible:
Always

Steps to Reproduce:
1. Push a non-po file project, such as a properties, utf8properties or xliff projects. 
2. Download a document as a po file.
3. Upload that po file
  
Actual results:
File Constants.po uploaded. There were some warnings, see below. 
 Could not find TextFlow for TextFlowTarget 2fd5df9452801bcc015367756752a895 with contents: [] 
  .... and so on ...

Expected results:
Push successfully.

Additional info:
Comment 1 Sean Flanigan 2012-11-07 01:01:37 EST
Isn't this a duplicate of bug 870876?
Comment 2 David Mason 2012-11-13 02:28:20 EST
Closing as duplicate.

*** This bug has been marked as a duplicate of bug 870876 ***

Note You need to log in before you can comment on or make changes to this bug.