This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 870998 - [ja_JP] Test case failure: Storage Tab: General sub-tab: unnecessary colon (":") between "Used: xxxxGB" line and NFS Export Path
[ja_JP] Test case failure: Storage Tab: General sub-tab: unnecessary colon ("...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Linux
medium Severity high
: ---
: 3.2.0
Assigned To: Einav Cohen
Pavel Stehlik
ux
: i18n, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 07:23 EDT by Yuko Katabami
Modified: 2013-06-11 04:22 EDT (History)
9 users (show)

See Also:
Fixed In Version: sf3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 883896 (view as bug list)
Environment:
Last Closed: 2013-06-11 04:18:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Storage main tab - General sub-tab (Japanese) (80.68 KB, image/png)
2012-12-04 17:27 EST, Einav Cohen
no flags Details
Fixed colon removed. (92.57 KB, image/png)
2013-01-09 00:15 EST, Lijun Li
no flags Details

  None (edit)
Description Yuko Katabami 2012-10-29 07:23:36 EDT
Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
unspecified

Steps to Reproduce: 
  * Portal should run in local language


  * Click on Storage Tab in Portal

  * In the Detail Pane, select General tab.






Actual results: 
There is a colon ":" between "Used: xxxxGB" line and NFS Export Path line.

Expected results:
It should not be there?
Comment 1 Shahar Havivi 2012-11-04 09:25:40 EST
The reason that you see : in Japanese is because of the Zenata string:
empty=\u3000

Please remove it, I saw 4 more entries at this file:
CommonApplicationConstants_ja.properties
Constants_ja.properties
ApplicationConstants_ja.properties
ApplicationConstants_ja.properties

I will add additional code fix for this bug.
Comment 2 Shahar Havivi 2012-11-04 10:03:45 EST
posted at: http://gerrit.ovirt.org/#/c/9012/
Comment 5 Einav Cohen 2012-11-08 12:12:07 EST
Hi Yuko, just making sure that you saw Shahar's Comment #1. Thanks.
Comment 6 Yuko Katabami 2012-11-08 18:41:59 EST
Hi Einav and Shahar,

Sorry for my late response.
I have removed all entries of the space charaters where supposed to be empty and double checked.
Please let me know if you still have any problems.
Comment 7 Einav Cohen 2012-12-04 17:27:36 EST
Created attachment 657783 [details]
Storage main tab - General sub-tab (Japanese)
Comment 8 Einav Cohen 2012-12-04 17:30:07 EST
Yuko, I pulled updated strings from Zanata into the code and it seems that the problem has been fixed, however I am not absolutely sure, since no screen-shot has been provided when the BZ was reported.

Can you please confirm that the problem is indeed resolved (see attachment 657783 [details])?

[if so - feel free to move this BZ to MODIFIED. Thanks]
Comment 9 Yuko Katabami 2012-12-04 17:34:10 EST
Confirmed that it has been fixed. Thank you very much.
Comment 11 Einav Cohen 2012-12-20 10:33:54 EST
CodeChange (nothing to test here on English) - moving to VERIFIED.
Comment 12 Einav Cohen 2013-01-08 23:19:51 EST
(In reply to comment #11)
> CodeChange (nothing to test here on English) - moving to VERIFIED.

Fix still needs to be verified in Japanese (fix has simply removed the usage of the localized empty string) -> removing CodeChange keyword, moving to ON_QA on latest RHEV-M 3.2 version (sf3).
Comment 13 Lijun Li 2013-01-09 00:12:04 EST
Verified on the latest rhevm3.2 sf3 build, it's fixed.
[root@rhevm32 ~]# rpm -q rhevm rhevm-webadmin-portal
rhevm-3.2.0-4.el6ev.noarch
rhevm-webadmin-portal-3.2.0-4.el6ev.noarch

Please refer to the attached screen shot.

Thanks,
Robert
Comment 14 Lijun Li 2013-01-09 00:15:36 EST
Created attachment 675256 [details]
Fixed colon removed.
Comment 15 Itamar Heim 2013-06-11 04:18:16 EDT
3.2 has been released
Comment 16 Itamar Heim 2013-06-11 04:22:49 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.