Bug 871022 - satellite-sync from dump fails with "[Errno 22] Invalid argument" in fcntl.fcntl
satellite-sync from dump fails with "[Errno 22] Invalid argument" in fcntl.fcntl
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2012-10-29 08:21 EDT by Jan Hutař
Modified: 2013-03-06 13:34 EST (History)
0 users

See Also:
Fixed In Version: spacewalk-backend-1.9.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1130767 (view as bug list)
Environment:
Last Closed: 2013-03-06 13:34:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-10-29 08:21:15 EDT
Description of problem:
On some systems I have seen satellite-sync failing with "[Errno 22] Invalid argument" when syncing from dump on Fedora 17.


Version-Release number of selected component (if applicable):
spacewalk-backend-tools-1.8.82-1.fc17.noarch


How reproducible:
always


Steps to Reproduce:
1. Attempt to sync from dump using satellite-sync


Actual results:
+++ sending log as an email +++

SYNC ERROR: unhandled exception occurred:

(Check logs/email for potentially more detail)

IOError(22, 'Invalid argument')
[Errno 22] Invalid argument


Expected results:
Should work
Comment 1 Jan Hutař 2012-10-29 08:24:17 EDT
Traceback from mail:



22:49:15 
SYNC ERROR: unhandled exception occurred:

Exception reported from <fqdn>
Time: Thu Nov  1 22:49:15 2012
Exception type <type 'exceptions.IOError'>

Exception Handler Information
Traceback (most recent call last):
  File "/bin/satellite-sync", line 139, in main
    return satsync.Runner().main()
  File "/usr/lib/python2.7/site-packages/spacewalk/satellite_tools/satsync.py", line 225, in main
    ret = method()
  File "/usr/lib/python2.7/site-packages/spacewalk/satellite_tools/satsync.py", line 301, in _step_channels
    self.syncer.process_channels()
  File "/usr/lib/python2.7/site-packages/spacewalk/satellite_tools/satsync.py", line 682, in process_channels
    ch = self._channel_collection.get_channel(label, timestamp)
  File "/usr/lib/python2.7/site-packages/spacewalk/satellite_tools/sync_handlers.py", line 135, in get_channel
    return self._cache.cache_get(channel_label, timestamp=timestamp)
  File "/usr/lib/python2.7/site-packages/spacewalk/satellite_tools/syncCache.py", line 41, in cache_get
    compressed=self._compressed)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 80, in get
    return cache.get(name, modified)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 396, in get
    return self.cache.get(name, modified)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 366, in get
    pickled = self.cache.get(name, modified)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 324, in get
    fd = self.get_file(name, modified)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 351, in get_file
    compressed_file = self.cache.get_file(name, modified)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 293, in get_file
    fd = ReadLockedFile(name, modified)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 187, in __init__
    self.fd = self.get_fd(name, user, group, mode)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 216, in get_fd
    _lock(fd.fileno(), RDLOCK)
  File "/usr/lib/python2.7/site-packages/spacewalk/common/rhnCache.py", line 60, in _lock
    fcntl.fcntl(fd, fcntl.F_SETLKW, lock)
IOError: [Errno 22] Invalid argument
Comment 3 Michael Mráka 2012-11-23 11:12:37 EST
This issue should be fixed in spacewalk master since 
commit c72371474ca4d874027babb7918ed496425cc98e
    Using fcntl.lockf should avoid any need for packing.
Comment 4 Stephen Herr 2013-03-01 12:06:49 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 5 Stephen Herr 2013-03-06 13:34:11 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.