Bug 871082 - dropped to maintenance prompt when cryptsetup times out
dropped to maintenance prompt when cryptsetup times out
Status: CLOSED DUPLICATE of bug 861123
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 11:09 EDT by Matthew Miller
Modified: 2012-10-29 12:01 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 12:01:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from boot (29.35 KB, text/plain)
2012-10-29 11:09 EDT, Matthew Miller
no flags Details

  None (edit)
Description Matthew Miller 2012-10-29 11:09:34 EDT
Created attachment 635044 [details]
log from boot

I often turn on my laptop and then look away while the boot process starts. I found that many times, when I look back, the system is in text mode with a prompt to enter the root password or ctrl-d to continue.

Upon investigation, the problem is simply that the password prompt for unlocking /home is timing out, and that results in dropping to this prompt.

(I have /home encrypted but not the system partition.)


I suppose the correct behavior is to keep the GUI and to re-prompt, possibly with a button for "enter maintenance mode" appearing.

Alternately, just don't time out.


Attached, boot log from the "failed" boot.


systemd-195-2.fc18.x86_64
Comment 1 Michal Schmidt 2012-10-29 11:28:56 EDT
This looks like bug 861123.
Comment 2 Michal Schmidt 2012-10-29 11:33:50 EDT
(In reply to comment #1)
> This looks like bug 861123.

Also try "timeout=0" option in /etc/crypttab
Comment 3 Matthew Miller 2012-10-29 12:01:43 EDT
Yep, duplicate.

*** This bug has been marked as a duplicate of bug 861123 ***

Note You need to log in before you can comment on or make changes to this bug.