Bug 871087 - Action buttons (lists of possible actions) in Reclaim disk space dialog are not visible
Action buttons (lists of possible actions) in Reclaim disk space dialog are n...
Status: CLOSED DUPLICATE of bug 866209
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 11:22 EDT by Martin Banas
Modified: 2013-03-12 10:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 14:50:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reclaim disk space dialog (157.05 KB, image/png)
2012-10-29 11:22 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2012-10-29 11:22:27 EDT
Created attachment 635048 [details]
Reclaim disk space dialog

Description of problem:
The action buttons (preserve / shrink / delete) are not visible to user. Now it's just a text, you need to select the line and then click again to the text "preserve" to find out that the text is actually a list where you can choose the options.

The other error I see is that I need to hold the mouse button, in other case the list will disappear. I don't think this is a good idea since sometimes it's quite hard to do that when e.g. using VNC with really slow connection.. 

Version-Release number of selected component (if applicable):
anaconda-18.21-1.fc18

How reproducible:
always

Steps to Reproduce:
1. Start installation
2. Select partitioning and click on reclaim disk space
3. See the dialog
  
Actual results:
1. action buttons (which means list of possible options) should be visible to user.
2. Double click is required to edit the action. Which means one click for selecting the line and second one for opening the list.
3. User needs to hold the mouse button when selecting the action. 

Expected results:
1. User should see that there's something he can change on the Reclaim disk space dialog. Which means list should look like list, not just like text.
2. When the buttons (list) is visible (it's not just a text), user should be able to open any list without the need to select the line first.
3. User should be able to open the list using one click, than release the mouse button, without closing the list of items.

Additional info:
Attached screenshot with current look.. Please let me know if you need anything else.
Comment 1 Chris Lumens 2012-10-30 11:04:19 EDT
Yeah, these are all problems with the GtkCellRendererCombo, which apparently aren't bugs according to the gtk component.
Comment 2 Chris Lumens 2012-10-30 14:50:12 EDT

*** This bug has been marked as a duplicate of bug 866209 ***

Note You need to log in before you can comment on or make changes to this bug.