Bug 871109 - Confusing text in label for checkbutton to use custom partitioning
Confusing text in label for checkbutton to use custom partitioning
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-29 12:14 EDT by David Lehman
Modified: 2012-11-22 16:36 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-18.24-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 16:36:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2012-10-29 12:14:52 EDT
Description of problem:
In the dialog shown when there is not enough space available on the selected disks to complete the installation, the label for the checkbutton to skip to custom partitions reads as follows:

  I don't need help; let me review & customize disk partitioning to reclaim
  space.

This has potential to confuse users. More accurate text would along the lines of this:

  I don't need help; let me customize disk partitioning.


Version-Release number of selected component (if applicable):
anaconda-18.21-1

How reproducible:
Always, given sufficient disk capacity and insufficient free disk space.
Comment 1 David Lehman 2012-10-29 12:16:29 EDT
I have a patch for this ready to be sent off for review.
Comment 2 Adam Williamson 2012-10-31 14:29:28 EDT
Discussed at 2012-10-31 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-31/f18beta-blocker-review-6.2012-10-31-16.00.log.txt . From an NTH process perspective this is approved - it's a minor safe change with a clear benefit and cannot be implemented with an update. We note however that there's the question of the string freeze: our approval of this as NTH doesn't constitute a string freeze exception, we're not the appropriate people to do that. The string freeze is a separate issue, so if it has implications here, we say in theory you should please also follow the appropriate process for a string freeze exception.
Comment 3 Fedora Update System 2012-10-31 22:50:58 EDT
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18
Comment 4 Adam Williamson 2012-11-01 00:43:27 EDT
Confirming this fix is in 18.22 as expected.
Comment 5 Fedora Update System 2012-11-01 14:26:26 EDT
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-11-02 00:05:27 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 7 Adam Williamson 2012-11-02 02:47:07 EDT
I think this somehow got lost from 18.23. smoke14 seems to be back to the old text.
Comment 8 David Lehman 2012-11-02 09:02:42 EDT
(In reply to comment #7)
> I think this somehow got lost from 18.23. smoke14 seems to be back to the
> old text.

Yeah, you're right. I took a glade patch that clobbered it.
Comment 9 Fedora Update System 2012-11-02 14:39:54 EDT
Package anaconda-18.23-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.23-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17509/anaconda-18.23-1.fc18
then log in and leave karma (feedback).
Comment 10 Adam Williamson 2012-11-22 16:36:59 EST
This is fixed again in recent builds, so closing.

Note You need to log in before you can comment on or make changes to this bug.