Bug 871125 - local client keyboard -> english keyboard mapping wrong causing reordering of guest keyboard layout
Summary: local client keyboard -> english keyboard mapping wrong causing reordering of...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: ---
Assignee: Marc-Andre Lureau
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-29 17:05 UTC by David Jaša
Modified: 2013-04-10 15:50 UTC (History)
7 users (show)

Fixed In Version: mingw-virt-viewer-0.5.3-15.el6
Doc Type: Bug Fix
Doc Text:
Previously, the English keyboard mapping of the client keyboard was incorrectly reordering the guest keyboard layout. The English keyboard has now been properly mapped.
Clone Of:
Environment:
Last Closed: 2012-12-04 17:59:12 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1525 0 normal SHIPPED_LIVE new package: mingw-virt-viewer 2012-12-04 22:56:09 UTC

Description David Jaša 2012-10-29 17:05:29 UTC
Description of problem:
local client keyboard -> english keyboard mapping wrong causing reordering of guest keyboard layout.

This bug makes e.g. impossible to write anything meaningful when both client and guest use the same layout that happens to be sufficiently divergent from basic en_US layout.
When you switch client layout to en_US, the problems are gone.

Version-Release number of selected component (if applicable):
mingw-virt-viewer 5,0,2,4
mingw-spice-gtk-0.12-6

How reproducible:
always

Steps to Reproduce:
1. switch client to french layout
2. switch guest to english layout
3. in some text input in the guest, type 6 keys next to tab, left to right
  
Actual results:
you see: azerty

Expected results:
you should see: qwerty
(aka only guest layout should matter)

Additional info:

Comment 1 Marc-Andre Lureau 2012-10-29 17:43:23 UTC
I can reproduce, looking at it

Comment 2 Marc-Andre Lureau 2012-10-30 11:22:22 UTC
sent patch to ML

Comment 7 errata-xmlrpc 2012-12-04 17:59:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1525.html


Note You need to log in before you can comment on or make changes to this bug.