Bug 871149 - bundle of erlang-snappy
bundle of erlang-snappy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: couchdb (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 14:14 EDT by Michael Scherer
Modified: 2013-02-01 23:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 23:25:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2012-10-29 14:14:26 EDT
Couchdb seems toi have a bundled version of erlang-snappy, which is against our policy, and that cause file conflict :
Erreur du contrôle de transaction :
  file /usr/lib64/erlang/lib/snappy-1.0.3/ebin/snappy.app from install of erlang-snappy-1.0.3-0.2.git80db168.fc18.x86_64 conflicts with file from package couchdb-1.2.0-1.fc18.x86_64
Comment 1 Michael Scherer 2012-10-29 14:16:12 EDT
It seems that couchdb also ship a copy of ejson, who is not in the repository for now, would you prefer a 2nd bug report for that ?
Comment 2 Peter Lemenkov 2012-10-29 14:29:17 EDT
(In reply to comment #0)
> Couchdb seems toi have a bundled version of erlang-snappy, which is against
> our policy, and that cause file conflict :
> Erreur du contrôle de transaction :
>   file /usr/lib64/erlang/lib/snappy-1.0.3/ebin/snappy.app from install of
> erlang-snappy-1.0.3-0.2.git80db168.fc18.x86_64 conflicts with file from
> package couchdb-1.2.0-1.fc18.x86_64

Yep. I'm aware of it - I hope to fix this before this weekend.


(In reply to comment #1)
> It seems that couchdb also ship a copy of ejson, who is not in the
> repository for now, would you prefer a 2nd bug report for that ?

Yes, please. That's another and more long story since this bundled library (ejson)  bundles another one library - I'm working on untangling this but no ETA yet. 

I hope it'll take me ~2 weeks but unfortunately I've got a couple of other Fedora-related urgent tasks (update Riak to 1.2.1 among them), not to mention other real-life issues.
Comment 3 Michael Scherer 2012-10-29 14:49:16 EDT
Ok done on 871155
Comment 4 Fedora Update System 2013-01-22 03:31:43 EST
couchdb-1.2.1-1.fc18.1 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/couchdb-1.2.1-1.fc18.1
Comment 5 Fedora Update System 2013-01-22 03:49:00 EST
couchdb-1.2.1-1.fc17.1 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/couchdb-1.2.1-1.fc17.1
Comment 6 Fedora Update System 2013-01-24 16:49:51 EST
Package couchdb-1.2.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing couchdb-1.2.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1375/couchdb-1.2.1-2.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-02-01 23:25:45 EST
couchdb-1.2.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-02-01 23:27:46 EST
couchdb-1.2.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.