Bug 871211 - Please update facter to the latest upstream (patch included)
Summary: Please update facter to the latest upstream (patch included)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: facter
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Stahnke
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-29 23:04 UTC by Michael Stahnke
Modified: 2013-04-19 17:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-19 08:36:35 UTC


Attachments (Terms of Use)
Patch to spec file etc (7.12 KB, application/octet-stream)
2012-10-29 23:04 UTC, Michael Stahnke
no flags Details

Description Michael Stahnke 2012-10-29 23:04:39 UTC
Created attachment 635249 [details]
Patch to spec file etc

Description of problem:
Facter is behind upstream.

Version-Release number of selected component (if applicable):
Currently is at 1.6.6, 1.6.13 is out and fully compatible.


How reproducible:
Download facter, notice it is out-of-date.



Additional info:

Happy to assist in this update for other Fedora/EPEL versions beyond Rawhide.

Comment 1 Fedora Update System 2012-11-05 07:04:45 UTC
facter-1.6.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/facter-1.6.14-1.fc18

Comment 2 Fedora Update System 2012-11-05 07:32:13 UTC
facter-1.6.14-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/facter-1.6.14-1.el6

Comment 3 Fedora Update System 2012-11-05 07:32:22 UTC
facter-1.6.14-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/facter-1.6.14-1.el5

Comment 4 Fedora Update System 2012-11-05 07:36:23 UTC
facter-1.6.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/facter-1.6.14-1.fc17

Comment 5 Fedora Update System 2012-11-05 17:02:51 UTC
Package facter-1.6.14-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing facter-1.6.14-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-13392/facter-1.6.14-1.el6
then log in and leave karma (feedback).

Comment 6 arthurguru 2012-11-07 22:56:10 UTC
I have two MTA hosts that run exactly the same software and both have been suffering the same puppet problem at the same time for a number of months.

I've just installed the latest epel-testing version of facter on one of the hosts and will report back if it solves this puppet problem.

Comment 7 Michael Stahnke 2012-11-08 19:04:28 UTC
Upstream bug for the facter/openstack issue reported: http://projects.puppetlabs.com/issues/17493

Comment 8 arthurguru 2012-11-09 04:30:16 UTC
Since the last 2 days on trialling two hosts that regularly report puppet hangs.

MTA1 host running facter-1.6.6-1.el6 (from epel repo)
Puppet daemon required a restart 3 times 

MTA2 host running facter-1.6.14-1.el6 (from epel-testing repo)
Puppet daemon required a restart 0 times

Comment 9 Michael Stahnke 2012-11-09 22:45:41 UTC
Probably going to add this patch: https://github.com/puppetlabs/facter/pull/351.patch which should fix the Ec2 issues.

Comment 10 arthurguru 2012-11-15 22:35:41 UTC
Since the last 8 days on trialling two hosts that regularly report puppet hangs.

MTA1 host running facter-1.6.6-1.el6 (from epel repo)
Puppet daemon required a restart 11 times 

MTA2 host running facter-1.6.14-1.el6 (from epel-testing repo)
Puppet daemon required a restart 0 times

How soon can we get a formal release of facter into the EPEL repo?

Comment 11 Fedora Update System 2012-11-28 22:36:58 UTC
facter-1.6.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/facter-1.6.15-1.fc17

Comment 12 Fedora Update System 2012-11-28 22:37:09 UTC
facter-1.6.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/facter-1.6.15-1.fc18

Comment 13 Fedora Update System 2012-11-28 22:56:52 UTC
facter-1.6.15-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/facter-1.6.15-1.el5

Comment 14 Fedora Update System 2012-11-28 22:57:02 UTC
facter-1.6.15-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/facter-1.6.15-1.el6

Comment 15 Fedora Update System 2012-12-04 18:54:10 UTC
facter-1.6.16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/facter-1.6.16-1.fc17

Comment 16 Fedora Update System 2012-12-04 18:54:24 UTC
facter-1.6.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/facter-1.6.16-1.fc18

Comment 17 Fedora Update System 2012-12-04 18:56:53 UTC
facter-1.6.16-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/facter-1.6.16-1.el6

Comment 18 Fedora Update System 2012-12-04 18:57:04 UTC
facter-1.6.16-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/facter-1.6.16-1.el5

Comment 19 Andreas Zuber 2012-12-11 10:27:46 UTC
There is an important fix since facter 1.6.14 regarding RHEL KVM detection:

https://projects.puppetlabs.com/issues/8210

It only works if virt-what is installed. Otherwise the virtual fact will not work correctly in some cases.

I suggest you add virt-what as a dependency to facter.

Comment 20 Fedora Update System 2012-12-19 08:36:37 UTC
facter-1.6.16-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-01-11 23:28:57 UTC
facter-1.6.16-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2013-03-19 17:04:49 UTC
facter-1.6.18-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/facter-1.6.18-1.fc17

Comment 23 Fedora Update System 2013-03-19 17:05:39 UTC
facter-1.6.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/facter-1.6.18-1.fc18

Comment 24 Fedora Update System 2013-03-19 17:06:18 UTC
facter-1.6.18-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/facter-1.6.18-1.el6

Comment 25 Fedora Update System 2013-03-19 17:06:58 UTC
facter-1.6.18-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/facter-1.6.18-1.el5

Comment 26 Fedora Update System 2013-03-29 01:22:25 UTC
facter-1.6.18-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2013-03-29 01:23:14 UTC
facter-1.6.18-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2013-04-03 14:26:59 UTC
facter-1.6.18-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/facter-1.6.18-2.el5

Comment 29 Fedora Update System 2013-04-03 14:27:50 UTC
facter-1.6.18-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/facter-1.6.18-2.el6

Comment 30 Fedora Update System 2013-04-03 23:24:25 UTC
facter-1.6.18-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/facter-1.6.18-3.el6

Comment 31 Fedora Update System 2013-04-03 23:25:49 UTC
facter-1.6.18-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/facter-1.6.18-3.el5

Comment 32 Fedora Update System 2013-04-19 17:01:53 UTC
facter-1.6.18-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2013-04-19 17:05:35 UTC
facter-1.6.18-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.