Bug 871212 - [RFE] Atomic persist config file
[RFE] Atomic persist config file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 19:08 EDT by Alon Bar-Lev
Modified: 2013-02-28 11:44 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-12.el6
Doc Type: Enhancement
Doc Text:
It is now possible to atomically persist configuration files. This feature allows users to update persisted files without overwriting the files' content and potentially breaking the system with misconfigured code.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:44:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alon Bar-Lev 2012-10-29 19:08:47 EDT
Hello,

Currently there is no way to perform atomic store of configuration file. The persistence API of ovirtnode.ovirtfunctions can fail in many stages and leave system in unpredictable state.

I suggest an API like:

persist(file, destination)

1. cp file /config/destination.tmp
2. mv /config/destination.tmp /config/destination
3. rebind /config/destination destination

This way we have either the content of the new or old file.

---

BTW:

Looking at code, please try to do as much as you can in python. I don't understand the reason of calling system utilities such as:

system("mkdir -p /config/" + dirname)
->os.makedirs(os.path.join('/config', dirname))

system("rm -f /config"+ filename)
->shutil.rmtree(os.path.join('/config', dirname))

system_closefds("echo "+filename+" >> /config/files")
->with open('/config/files', 'a') as f:
    f.write("%s\n" % filename)

ret = system_closefds("grep -q \"^$" + filename +"$\" " + \
                " /config/files 2> /dev/null")
->with open('/config/files', 'r') as f:
    if filename in f:
        ....
etc...

Using python only reduces the blocks that can fail, provide better control on code flow and much better perform.

In these small cases you must call external program, please try to avoid system() as it may route output and input of caller which is an unexpected behaviour of an API. Use subprocess.Popen().

Thank you.
Comment 16 errata-xmlrpc 2013-02-28 11:44:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.