Bug 871241 - VM's often need an xserver restart before ctrl+alt+f[2-6] have any effect
VM's often need an xserver restart before ctrl+alt+f[2-6] have any effect
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 22:49 EDT by Cole Robinson
Modified: 2012-11-26 20:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-26 20:43:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (58.09 KB, text/plain)
2012-10-29 22:51 EDT, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2012-10-29 22:49:52 EDT
F18 host, F18 guest, using qxl+spice, but also reproduced with cirrus + spice. Most times when I start the guest and it hits GDM, ctrl+alt+f[2-6] don't register any effect. If I log in, same result, no screen flicker or anything.

However if I telinit 3, login, telinit 5, ctrl+alt+* start working as expected, dropping me to a tty.

Reproduced with both virt-manager and virt-viewer so probably not an application issue.
Comment 1 Cole Robinson 2012-10-29 22:51:02 EDT
Created attachment 635291 [details]
Xorg.0.log
Comment 2 Stefan Hajnoczi 2012-11-01 10:51:18 EDT
I'm unable to reproduce this with a F18 guest with spice using virt-manager:

/usr/bin/qemu-kvm -name f18 -S -M pc-1.2 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -uuid a352d08e-d282-d66b-6e40-8280757d6686 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/f18.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=/var/lib/libvirt/images/f18.img,if=none,id=drive-virtio-disk0,format=raw,cache=none,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/home/stefanha/qemu/disk.img,if=none,id=drive-virtio-disk1,format=raw,cache=none,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x8,drive=drive-virtio-disk1,id=virtio-disk1 -drive if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=24 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:a2:b9:25,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7
Comment 3 Cole Robinson 2012-11-26 20:43:34 EST
Can't seem to reproduce again with a fully updated F18 vm, so closing.

Note You need to log in before you can comment on or make changes to this bug.