Bug 871252 - installing GNU Free gives broken Indic rendering for Serif
Summary: installing GNU Free gives broken Indic rendering for Serif
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnu-free-fonts
Version: 18
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 956192
TreeView+ depends on / blocked
 
Reported: 2012-10-30 03:57 UTC by Parag Nemade
Modified: 2013-12-20 02:03 UTC (History)
5 users (show)

Fixed In Version: gnu-free-fonts-20120503-6.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-24 20:23:11 UTC
Type: Bug


Attachments (Terms of Use)
Normal_rendering_Lohit_Devanagari (262.37 KB, image/png)
2012-10-30 06:19 UTC, Parag Nemade
no flags Details
Broken_rendering_Gnu_Free_serif (305.76 KB, image/png)
2012-10-30 06:19 UTC, Parag Nemade
no flags Details
Patch to remove devanagari script langset from gnu-free-serif (800 bytes, patch)
2012-11-01 07:02 UTC, Pravin Satpute
no flags Details | Diff
Patch to modify 69-gnu-free-sans and 69-gnu-free-serif conf file (1.42 KB, patch)
2013-05-15 11:07 UTC, Pravin Satpute
no flags Details | Diff

Description Parag Nemade 2012-10-30 03:57:12 UTC
Description of problem:
I found that rendering changed for http://online2.esakal.com/esakal/index.htm when I installed gnu-free-fonts all subpackages.

Version-Release number of selected component (if applicable):
gnu-free-sans-fonts-20120503-2.fc18.noarch
gnu-free-serif-fonts-20120503-2.fc18.noarch

How reproducible:
always

Steps to Reproduce:
1. open in Firefox http://online2.esakal.com/esakal/index.htm
2. now install gnu-free-* fonts
3. reload this page and rendering changes
  
Actual results:
rendering changed and is broken

Expected results:
rendering should not break

Additional info:

But this is happening with this website only. When tried to check with http://mr.wikipedia.org , rendering looked same even after gnu-free font installation.

Comment 1 Parag Nemade 2012-10-30 06:19:13 UTC
Created attachment 635338 [details]
Normal_rendering_Lohit_Devanagari

Comment 2 Parag Nemade 2012-10-30 06:19:45 UTC
Created attachment 635340 [details]
Broken_rendering_Gnu_Free_serif

Comment 3 Parag Nemade 2012-10-30 06:43:32 UTC
Its found that Lohit have no serif fonts. Firefox needs serif fonts. It finds Gnu free fonts or Samyak fonts and changes rendering to it.

Comment 4 Pravin Satpute 2012-10-30 06:47:28 UTC
gnu-free-serif has characters but does not have Open type rules required to render complex Indian scripts.

I am seeing one alternative here.

May be we can add one more .conf file in Lohit with 68 priority, it should override gnu-free

samyak has 67, so 

1. if someone install samyak, he will get samyak as a serif fonts
2. Even if someone install gnu-free, still he will get lohit as a fallback serif

will this work? i am testing though

Comment 5 Akira TAGOH 2012-10-30 07:04:55 UTC
There are two problems here:

 1. the side effect of the lang testing in Lohit and so. this gives a priority to gnu-free-fonts on non-Indic locales for Indic glyphs or when contents doesn't have any language information.

 2. no serif fonts in Lohit.

The suggestion at comment#4 may helps for case 2. but not 1.

Comment 6 Akira TAGOH 2012-10-30 07:09:45 UTC
I may suggest for a workaround to get rid of the problematic language coverage from the fonts. it's available since 2.9.0 so only work on f18 so far and no plans for f17 and earlier.

  <match target="scan">
    <test name="family">
      <string>FreeSans</string>
    </test>
    <edit name="lang" mode="assign">
      <minus>
        <name>lang</name>
        <langset>
          <string>lang_code_what_you_want_to_remove_from_cache</string>
          ...
        </langset>
      </minus>
    </edit>
  </match>

Comment 7 Pravin Satpute 2012-11-01 07:02:28 UTC
Created attachment 636471 [details]
Patch to remove devanagari script langset from gnu-free-serif

Tested now, Lohit is getting selected even for serif after having gnu-free-serif installed.

Thought there are other Indian script characters are available in gnu-free-serif, still Lohit is getting selected for those languages, so looks no issue presently.

Comment 8 Akira TAGOH 2012-11-01 08:23:34 UTC
How about for FreeSans and FreeMono? I guess there still may be the issue if one is on en locale say?

Comment 9 Pravin Satpute 2012-11-03 05:57:42 UTC
For Sans no issue, since we are installing Lohit Devanagari by default. I will check for Mono.

Comment 10 Jens Petersen 2012-11-05 04:40:16 UTC
FreeMono has no Indic coverage at least according to
http://www.gnu.org/software/freefont/coverage.html
though best to check to be sure.

Comment 11 Pravin Satpute 2012-11-05 07:19:40 UTC
Thanks Jens,
Yes right, just gone through the sfd file of FreeMono.sfd, it does not have Devanagari characters.

Comment 12 Pravin Satpute 2013-01-11 12:29:50 UTC
Devanagari broken very badly in online new paper..
Will be very helpful if someone build this quickly with the patch provided.

Comment 13 Gwyn Ciesla 2013-01-11 13:57:32 UTC
Sorry for the delay, building now.

Comment 14 Fedora Update System 2013-01-11 14:14:33 UTC
gnu-free-fonts-20120503-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnu-free-fonts-20120503-4.fc18

Comment 15 Fedora Update System 2013-01-12 15:17:01 UTC
Package gnu-free-fonts-20120503-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnu-free-fonts-20120503-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0681/gnu-free-fonts-20120503-4.fc18
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2013-01-23 16:06:00 UTC
gnu-free-fonts-20120503-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Pravin Satpute 2013-05-15 11:07:07 UTC
Created attachment 748196 [details]
Patch to modify 69-gnu-free-sans and 69-gnu-free-serif conf file

Hi Jon,

  Last time we missed to modify 69-gnu-free-sans therefor still gnome-shell selects FreeSans as a default font for Indian locales instead of default font Lohit.

  Also we should 'minus' 3 more locales "as, bn and pa" from 69-gnu-free-serif.conf file, adding that as a next patch.

  This patch fix this issue. I have verified this issue with srpm http://pravins.fedorapeople.org/gnu-free-fonts-20120503-6.fc18.src.rpm 
 
  It will be very helpful if you can find some time and build this quickly.

Thanks.

Comment 18 Gwyn Ciesla 2013-05-15 13:00:16 UTC
On it's way.

Comment 19 Fedora Update System 2013-05-15 13:17:12 UTC
gnu-free-fonts-20120503-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnu-free-fonts-20120503-6.fc19

Comment 20 Fedora Update System 2013-05-15 13:17:28 UTC
gnu-free-fonts-20120503-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnu-free-fonts-20120503-6.fc18

Comment 21 Fedora Update System 2013-05-16 02:53:39 UTC
Package gnu-free-fonts-20120503-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnu-free-fonts-20120503-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8302/gnu-free-fonts-20120503-6.fc18
then log in and leave karma (feedback).

Comment 22 Fedora Update System 2013-05-24 20:23:11 UTC
gnu-free-fonts-20120503-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2013-12-20 02:03:16 UTC
gnu-free-fonts-20120503-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.