This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 871286 - qemu tapsets use the reserved 'function' keyword
qemu tapsets use the reserved 'function' keyword
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-30 03:00 EDT by Josh Stone
Modified: 2013-01-09 07:10 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 14:37:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Stone 2012-10-30 03:00:09 EDT
Description of problem:
The tapsets installed by qemu into /usr/share/systemtap/tapset/ try to use the name 'function' for a variable, but this is a reserved keyword.  This causes many warnings on pretty much any use of systemtap.  (stap will still run fine, provided you weren't hoping to use anything defined by those qemu*.stp)

Version-Release number of selected component (if applicable):
qemu-user-1.2.0-17.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. stap -l begin
  
Actual results:
Many parse errors across qemu tapsets, all like:
> parse error: expected statement
> 	saw: keyword at /usr/share/systemtap/tapset/qemu-x86_64.stp:1455:3
>      source:   function = $arg3;
>                ^
> parse error: expected identifier
> 	saw: operator '=' at /usr/share/systemtap/tapset/qemu-x86_64.stp:1455:12
>      source:   function = $arg3;
>                         ^
> 2 parse errors.

Expected results:
For "stap -l begin", it should just print "begin" with no errors.

Additional info:
This is related to the problem in bug #831763, just with 'function' this time.  The error looks like the same place in every qemu*.stp, just varying on which qemu binary is referenced:

1451 probe qemu.user.x86_64.usb_uas_tmf_unsupported = process("/usr/bin/qemu-x86_64").mark("usb_uas_tmf_unsupported")
1452 {
1453   addr = $arg1;
1454   tag = $arg2;
1455   function = $arg3;
1456 }
Comment 1 Fedora Update System 2012-10-31 08:53:19 EDT
qemu-1.2.0-18.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.0-18.fc18
Comment 2 Fedora Update System 2012-10-31 14:11:10 EDT
Package qemu-1.2.0-18.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.2.0-18.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17353/qemu-1.2.0-18.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-11-01 09:05:58 EDT
qemu-1.2.0-19.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.0-19.fc18
Comment 4 Cole Robinson 2012-11-28 14:37:39 EST
In stable now

Note You need to log in before you can comment on or make changes to this bug.