Bug 871365 - [RESTAPI] inherited perms are not seen via RESTAPI
[RESTAPI] inherited perms are not seen via RESTAPI
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.2.0
Assigned To: Ravi Nori
Ondra Machacek
infra
:
: 874705 (view as bug list)
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-10-30 06:25 EDT by Ondra Machacek
Modified: 2016-02-10 14:43 EST (History)
7 users (show)

See Also:
Fixed In Version: sf4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2012-10-30 06:25:20 EDT
Description of problem:


Version-Release number of selected component (if applicable):
si21

How reproducible:
always

Steps to Reproduce:
1. In webadmin add some permissions on DC.
2. Via RESTAPI check pesmissions of cluster that is in same DC, that have been added permissions.
  
Actual results:
No inherited permissions are seen.

Expected results:
Inherited permissions should be seen.

Additional info:
curl ... -u $ADMIN https://10.34.63.30:443/api/clusters/cluster-id/permissions

>>>
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<permissions/>

In webadmin, inherited permissions can be seen under clusters/permissions. Via RESTAPI only permissions that were added directly are seen.
Comment 1 Michael Pasternak 2012-11-11 02:44:21 EST
*** Bug 874705 has been marked as a duplicate of this bug. ***
Comment 2 Ravi Nori 2012-11-14 09:48:54 EST
link : http://gerrit.ovirt.org/#/c/9243/

change id : Ic1a05d64ed61ae2bcf813b926bb548842bada237
Comment 3 Michael Pasternak 2012-11-14 12:07:43 EST
*** Bug 874705 has been marked as a duplicate of this bug. ***
Comment 5 Itamar Heim 2013-06-11 04:26:47 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 04:26:52 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.