Bug 871482 - input method switch delay
input method switch delay
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-30 10:01 EDT by sangu
Modified: 2013-06-26 21:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: ibus-1.5.2-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 21:56:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2012-10-30 10:01:48 EDT
Description of problem:
input method switch delay
Click ctrl + space, EN < delay > 한

Version-Release number of selected component (if applicable):
1.4.99.20121006-2.fc18

How reproducible:
always

Steps to Reproduce:
1. ctrl + space
2. 
3.
  
Actual results:


Expected results:


Additional info:
gnome-settings-daemon-3.6.1-3.fc18.x86_64
control-center-3.6.2-1.fc18.x86_64
ibus-hangul-1.4.1-5.fc18.x86_64
Comment 1 sangu 2012-10-31 07:04:15 EDT
built input methd in emacs vs ibus in gnome 3.6

ctrl + \ in emacs 
After down key event, switch

ctrl + space in gnome 3.6 
After down key and up key event, switch
Comment 2 fujiwara 2012-11-01 22:56:45 EDT
I thought the problem could be happened but probably I need to investigate it with detail.

(In reply to comment #1)
> built input methd in emacs vs ibus in gnome 3.6
> 
> ctrl + \ in emacs 
> After down key event, switch
> 
> ctrl + space in gnome 3.6 
> After down key and up key event, switch

Probably I think the Ctrl + \ is provided by emacs and it would have the different implementation.

ibus 1.3 switches an input method engine between ON and OFF so the ibus hangul engine is launched from the beginning.

ibus 1.5 switches an xkb engine and input method engine so at first 'us' keyboard engine is launched but hangul engine is not launched until Ctrl+space is pressed so the delay could be happened.
Comment 3 Rui Matos 2012-11-05 03:41:04 EST
So, this is not a matter of "delay" but more of "when" the switch is triggered, right?

We do indeed only trigger the switch on key release.
Comment 4 fujiwara 2012-11-06 06:39:55 EST
(In reply to comment #0)
> Description of problem:
> input method switch delay
> Click ctrl + space, EN < delay > 한

Do you mean your problem exists in gnome-shell only but not gtk based ibus(metacity + gnome-panel or xfce or else) ?
Comment 5 fujiwara 2012-12-04 03:43:36 EST
(In reply to comment #4)
> (In reply to comment #0)
> > Description of problem:
> > input method switch delay
> > Click ctrl + space, EN < delay > 한
> 
> Do you mean your problem exists in gnome-shell only but not gtk based
> ibus(metacity + gnome-panel or xfce or else) ?

Are you able to reply my question?
I don't understand your problem.
Comment 6 Changwoo Ryu 2013-02-13 18:20:35 EST
The problem is, this input switch shortcut currently works on RELEASE event since GNOME 3.6, while conventionally Hangul toggle key has worked on PRESS since the beginning of PC.

See https://bugzilla.gnome.org/show_bug.cgi?id=693747
Comment 7 Fedora Update System 2013-04-22 06:50:32 EDT
ibus-1.5.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-6209/ibus-1.5.2-2.fc18
Comment 8 Fedora Update System 2013-04-22 06:51:30 EDT
ibus-1.5.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2013-6220/ibus-1.5.2-2.fc17
Comment 9 Fedora Update System 2013-05-01 23:51:36 EDT
Package ibus-1.5.2-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.5.2-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6220/ibus-1.5.2-3.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-06-26 21:56:03 EDT
ibus-1.5.2-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-06-26 21:56:58 EDT
ibus-1.5.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.