This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 871537 - [RFE] Username cannot contain characters other than alpha numerals,'_', '-', can not resume after failure
[RFE] Username cannot contain characters other than alpha numerals,'_', '-', ...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
Nightly
Unspecified Linux
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Adam Price
Katello QA List
: FutureFeature, Reopened, Triaged
Depends On: 813291
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-10-30 12:19 EDT by Partha Aji
Modified: 2014-09-18 11:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 813291
Environment:
Last Closed: 2014-06-25 11:46:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Partha Aji 2012-10-30 12:19:50 EDT
+++ This bug was initially created as a clone of Bug #813291 +++

Created attachment 578013 [details]
db_seed.log

Description of problem:

We use email addresses as username in RHN/RHSM (for example our QA account is qa@redhat.com). While SAM is supposed to act as sort of proxy to RHSM, I've expected it to support such user names too.

So I tried:

# katello-configure --deployment=sam --user-name=qa@redhat.com --user-pass=redhatqa --org-name="Red Hat"

and I got failure (in the log):

Validation failed: Username cannot contain characters other than alpha numerals,'_', '-'.

Then I tried:

# katello-configure --deployment=sam --user-name=admin --user-pass=admin --org-name="Red Hat"

and I got the same failure again.


Version-Release number of selected component (if applicable):
katello-configure-0.1.107-1.el6.noarch

How reproducible:
Install RHEL-6.2 GA and register to RHN, add SAM-2012-04-12.2 repository.

Steps to Reproduce:
1. yum -y install katello-headpin-all
2. katello-configure --deployment=sam --user-name=qa@redhat.com --user-pass=redhatqa --org-name="Red Hat"
3. katello-configure --deployment=sam --user-name=admin --user-pass=admin --org-name="Red Hat"
  
Actual results:

[root@hp-dl360g5-01 ~]# katello-configure --deployment=sam --user-name=qa@redhat.com --user-pass=redhatqa --org-name="Red Hat"
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20120417-072817/main.log]
Creating Katello database user
############################################################ ... OK
Creating Katello database
############################################################ ... OK
Creating Candlepin database user
############################################################ ... OK
Creating Candlepin database
############################################################ ... OK
Candlepin setup
############################################################ ... OK
Populating Katello database schema
############################################################ ... OK
Initializing Katello data
###########################################################
  Failed, please check [/var/log/katello/katello-configure/db_seed.log]
[root@hp-dl360g5-01 ~]# echo $?
6
[root@hp-dl360g5-01 ~]# katello-configure --deployment=sam --user-name=admin --user-pass=admin --org-name="Red Hat"
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20120417-073559/main.log]
Initializing Katello data
###########################################################
  Failed, please check [/var/log/katello/katello-configure/db_seed.log]
[root@hp-dl360g5-01 ~]# 


Expected results:
1. katello-configure should support '@' in user names.
2. katello-configure should either refuse wrong the username beforehand or be able to resume, when run again with correct params.


Additional info:
db_seed.log attached

--- Additional comment from pm-rhel@redhat.com on 2012-04-17 08:13:59 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from pm-rhel@redhat.com on 2012-04-17 08:14:41 EDT ---

Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.

--- Additional comment from pm-rhel@redhat.com on 2012-04-17 08:33:58 EDT ---

Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.

--- Additional comment from bkearney@redhat.com on 2012-04-27 13:49:55 EDT ---

Did not make it in. Moving to 1.2.

--- Additional comment from tomckay@redhat.com on 2012-10-29 13:56:49 EDT ---

We will allow these usernames in headpin mode only for now. Katello will remain restrictive until pulp is fixed.
Comment 1 Partha Aji 2012-10-30 12:22:47 EDT
Short version. 

We need to allow @ and "." in usernames. Pulp v2 does not like these characters (even though they have an RFE on it). So either we need to change katello to use user db ids for pulp username or wait for pulp to accept everything. We may need to do the db id or UUID for i18n usernames also in the future..
Comment 2 Tom McKay 2012-10-30 12:30:54 EDT
Note: We will allow full utf8 w/o restrictions for user names.
Comment 4 Tom McKay 2012-11-30 08:44:20 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=813291
Comment 5 Mike McCune 2013-09-19 22:30:09 EDT
This bug was mistakenly closed during a triage process.  Moving back to MODIFIED or ON_QA depending
Comment 6 Bryan Kearney 2013-09-23 10:29:27 EDT
upstream is fixed, moving to ON_QA
Comment 7 sthirugn@redhat.com 2014-06-25 11:46:38 EDT
We currently support all characters for username and we escape the html characters while displaying.

Note You need to log in before you can comment on or make changes to this bug.