Bug 871583 - bind restart failing when connecting to ipa-server with failure of ldap.so of undefined symbol: dns_view_flushnode
bind restart failing when connecting to ipa-server with failure of ldap.so of...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind-dyndb-ldap (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity unspecified
: rc
: ---
Assigned To: Adam Tkac
Namita Soman
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-30 15:13 EDT by Michael Gregg
Modified: 2014-08-05 07:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:58:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ipa server install log. (3.48 MB, application/x-gzip)
2012-10-30 15:19 EDT, Michael Gregg
no flags Details
/var/log/messages with bind failure in it (71.53 KB, application/octet-stream)
2012-10-30 15:34 EDT, Michael Gregg
no flags Details

  None (edit)
Description Michael Gregg 2012-10-30 15:13:17 EDT
Description of problem:
After running ipa-server-install, bind does not seem to connect to the ldap server.
Reported error is: failed to dynamically load driver 'ldap.so': /usr/lib64/bind/ldap.so: undefined symbol: dns_view_flushnode

I am unable to determine if it's a problem with ipa, or, bind-dyndb-ldap

Version-Release number of selected component (if applicable):
ipa-server-3.0.0-106.20121030T0103zgit63ae7a2.el6.x86_64
bind-dyndb-ldap-2.1-1.el6.x86_64

How reproducible:
always with build from 10-30-2012

Steps to Reproduce:
1. ipa-server-install  --setup-dns --forwarder=10.14.63.12 --hostname=ipaqavmf.testrelm.com -r TESTRELM.COM -n testrelm.com -p Secret123 -P Secret123 -a Secret123 -U
  
Actual results:

Oct 30 14:56:33 ipaqavmf named[10857]: set up managed keys zone for view _default, file 'dynamic/managed-keys.bind'

Oct 30 14:56:33 ipaqavmf named[10857]: failed to dynamically load driver 'ldap.so': /usr/lib64/bind/ldap.so: undefined symbol: dns_view_flushnode


Additional info:
Comment 2 Michael Gregg 2012-10-30 15:19:13 EDT
Created attachment 635736 [details]
ipa server install log.
Comment 4 Michael Gregg 2012-10-30 15:34:41 EDT
Created attachment 635746 [details]
/var/log/messages with bind failure in it
Comment 11 Namita Soman 2012-11-15 11:53:09 EST
Verified ipa-server install was successful, and didn't see the errors above. 

Verified using:
ipa-server-3.0.0-8.el6.x86_64
bind-dyndb-ldap-2.3-1.el6.x86_64
bind-libs-9.8.2-0.16.rc1.el6.x86_64
Comment 13 errata-xmlrpc 2013-02-21 03:58:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0359.html

Note You need to log in before you can comment on or make changes to this bug.