Bug 871768 - power management: Fence Host fails if something went wrong in FenceQuietTimeBetweenOperationsInSec window [180seconds]
power management: Fence Host fails if something went wrong in FenceQuietTimeB...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.0
Assigned To: Eli Mesika
Tareq Alayan
infra
: ZStream
Depends On:
Blocks: 879719 915537
  Show dependency treegraph
 
Reported: 2012-10-31 06:55 EDT by Tareq Alayan
Modified: 2016-02-10 14:20 EST (History)
12 users (show)

See Also:
Fixed In Version: sf1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 879719 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
engin.log (302.35 KB, application/x-gzip)
2012-10-31 06:59 EDT, Tareq Alayan
no flags Details

  None (edit)
Description Tareq Alayan 2012-10-31 06:55:09 EDT
Description of problem:
The problem is that we will stay with unresponsive host forever unless manually restarted.

Version-Release number of selected component (if applicable):
si22.1

Steps to Reproduce:
1. Assume you have 2 hosts aqua1, aqua2
2. Restart aqua1 via power management [Result: aqua1 is rebooted and up again within 90sec]
3. VDSMD on aqua1 crashed or stopped. [Result: aqua2 will send pmCommand reboot to aqua1]
The reboot attempt will fail because 180sec didn't pass yet [FenceQuietTimeBetweenOperationsInSec=180sec]
  
Actual results:
aqua1 is unresposive and vdsmd is down

Expected results:
Consider to send 2nd or 3rd reboot attempt to make sure the other host is up
Comment 1 Tareq Alayan 2012-10-31 06:59:54 EDT
Created attachment 636019 [details]
engin.log
Comment 2 Eli Mesika 2012-11-13 07:01:15 EST
http://gerrit.ovirt.org/#/c/9211/1
Comment 3 Eli Mesika 2012-11-20 04:37:58 EST
fixed at commit : cb564a3
Comment 5 Tareq Alayan 2013-01-08 09:23:57 EST
verified.
reboot is done after vdsmd is down in the 180 sec window.
Comment 6 Itamar Heim 2013-06-11 04:45:30 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 04:45:30 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 04:45:34 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 04:51:36 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 05:22:33 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.