Bug 871792 - Ldap Authentication setup for SAM 1.2 puddle failed
Ldap Authentication setup for SAM 1.2 puddle failed
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Katello Bug Bin
Tazim Kolhar
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-10-31 08:04 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 11:13:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Admin login (37.19 KB, image/png)
2012-10-31 08:04 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-10-31 08:04:31 EDT
Created attachment 636082 [details]
Admin login

Description of problem:
Configuring local ldap for sam1.2 puddle failed

Version-Release number of selected component (if applicable):

# rpm -qa | grep katello
katello-configure-1.2.0-1h.el6_3.noarch
katello-headpin-all-1.2.1-7h.el6_3.noarch
katello-cli-1.2.1-1h.el6_3.noarch
katello-selinux-1.2.0-1h.el6_3.noarch
katello-glue-candlepin-1.2.1-7h.el6_3.noarch
katello-certs-tools-1.2.0-1h.el6_3.noarch
katello-headpin-1.2.1-7h.el6_3.noarch
katello-common-1.2.1-7h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.2.1-1h.el6_3.noarch
How reproducible:


Steps to Reproduce:
1.# yum install -y katello-headpin-all
2.# # katello-configure --deployment=sam --ldap-server=qeldap.usersys.redhat.com --auth-method=ldap --ldap-users-basedn='ou=People,dc=redhat,dc=com' --ldap-group-basedn='ou=Groups,dc=redhat,dc=com' --ldap-roles=true --user-name admin --user-pass admin --reset-data=YES 
3.
  
Actual results:
Unable to login using user admin/admin

Expected results:

Ldap configuration successful with login allowed
Additional info:
Comment 1 Jordan OMara 2012-11-07 11:13:36 EST
the password used during katello-configure does NOT change the ldap user's password. admin/admin will only work if that is their password in your ldap config

working as intended
Comment 2 Tazim Kolhar 2012-11-23 05:28:59 EST
Agreed :

1.) A valid ldap_user / ldap_password should be used during katello-configure to
use ldap authentication with sam.

  
2.) katello-configure does NOT change ldap user's password.

3.) NOT_A_BUG

Note You need to log in before you can comment on or make changes to this bug.