This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 871794 - Creating a user using the i18n characters failed
Creating a user using the i18n characters failed
Status: CLOSED DUPLICATE of bug 813291
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Price
Tazim Kolhar
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 08:16 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-31 10:00:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
User name i18n (72.11 KB, image/png)
2012-10-31 08:16 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-10-31 08:16:54 EDT
Created attachment 636083 [details]
User name i18n

Description of problem:
Creating a user using the i18n characters failed

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-configure-1.2.0-1h.el6_3.noarch
katello-headpin-all-1.2.1-7h.el6_3.noarch
katello-cli-1.2.1-1h.el6_3.noarch
katello-selinux-1.2.0-1h.el6_3.noarch
katello-glue-candlepin-1.2.1-7h.el6_3.noarch
katello-certs-tools-1.2.0-1h.el6_3.noarch
katello-headpin-1.2.1-7h.el6_3.noarch
katello-common-1.2.1-7h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.2.1-1h.el6_3.noarch


How reproducible:
yum install -y katello-headpin-all
katello-configure --deployment=sam

Steps to Reproduce:
1.Login to SAM UI
2.Navigate Administer -> Users
3.Click admin . Change the language to 'ja'
4.Click + New User
5.Enter user name using some i18n character
6. Add other details
  
Actual results:

User creation failed
Expected results:
User creation should be allowed

Additional info:
Comment 1 Adam Price 2012-10-31 09:00:36 EDT
what's the exact error message? changes were made last sprint to enforce ascii characters because of the some pulp limitations.

https://github.com/Katello/katello/commit/9c5e2918494c5e1128df82b2bbf2c3d078a8e528
Comment 2 Tazim Kolhar 2012-10-31 09:12:30 EDT
Hi


I had documented this test case in the test run :
https://tcms.engineering.redhat.com/case/195552/?from_plan=6660

Earlier the previous versions of SAM (1.0 and 1.1)
supported creating users using i18n characters also.

is that dropped for the new version (SAM 1.2) ?
if so then please, update accordingly so that I can modify the test case .
Comment 3 Tom McKay 2012-10-31 09:14:17 EDT
Closing as duplicate. Available for testing in katello master

*** This bug has been marked as a duplicate of bug 813291 ***
Comment 4 Adam Price 2012-10-31 09:58:50 EDT
this is a regression due to commit:
https://github.com/Katello/katello/commit/9c5e2918494c5e1128df82b2bbf2c3d078a8e528
Comment 5 Adam Price 2012-10-31 10:00:53 EDT

*** This bug has been marked as a duplicate of bug 813291 ***

Note You need to log in before you can comment on or make changes to this bug.