This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 871974 - Add availability type REMOVED to AvailabilityType class
Add availability type REMOVED to AvailabilityType class
Status: CLOSED DUPLICATE of bug 1093822
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 17:33 EDT by Elias Ross
Modified: 2014-05-02 17:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 17:05:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Elias Ross 2012-10-31 17:33:19 EDT
Reason is explained here: https://community.jboss.org/thread/212115

Here's the JavaDoc showing the use cases for this enum type.

public enum AvailabilityType {

    /**
     * Resource was externally removed.
     * Example situations:
     * <ul>
     * <li>For a server resource, the agent observes the server is no longer installed.</li>
     * <li>For a .war deployment, the .war is no longer running on the server</li>
     * <li>For a file, the agent observes the file is no longer on the file system.</li>
     * <li>For a database table, the agent sees the table was removed.</li>
     * </ul>
     * The difference between REMOVED and DOWN is that REMOVED resources were
     * likely intentionally removed and advises administrators that this
     * resource should no longer be inventoried.
     * <p/>
     * This availability should only be used if the agent is certain the
     * resource was removed. These are examples where DOWN would be the correct
     * type:
     * <ul>
     * <li>For a database table, the agent has no permissions to access the
     * parent schema. It is possible the table still exists.</li>
     * <li>For a file, the agent cannot access the parent's directory.</li>
     * <li>For a .war file, the server was shut down as part of upgrade.</li>
     * </ul>
     * As a rule of thumb, if the parent of a resource is available,
     * and if at least one 'siblings' of a resource are available,
     * but this particular resource is absent, then it is suggested to
     * return this availability type.
     */
    REMOVED
    ;
Comment 1 Jay Shaughnessy 2014-05-02 14:45:19 EDT
Hi Elias, 

This has been something we've thought about for a while. Bug 1093822 is being worked on and has some overlap with this RFE.  Please check it out and comment. Thanks!
Comment 2 Elias Ross 2014-05-02 16:56:49 EDT
This is exactly what I was after.

You can mark this as a duplicate.
Comment 3 Elias Ross 2014-05-02 16:57:04 EDT
This is exactly what I was after.

You can mark this as a duplicate.
Comment 4 Jay Shaughnessy 2014-05-02 17:05:53 EDT
Excellent, thanks.

*** This bug has been marked as a duplicate of bug 1093822 ***

Note You need to log in before you can comment on or make changes to this bug.