Bug 871986 - [RFE] Striping should have optional parity/checksum
[RFE] Striping should have optional parity/checksum
Status: CLOSED DUPLICATE of bug 1118629
Product: GlusterFS
Classification: Community
Component: stripe (Show other bugs)
mainline
All All
medium Severity unspecified
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 18:30 EDT by Dynamic Packet
Modified: 2016-02-17 19:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-27 09:21:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dynamic Packet 2012-10-31 18:30:41 EDT
Description of problem:

 Striping currently behaves only like RAID-0. It would be great if there could be an option to have a parity brick. The idea is to behave more like RAID-5 (or possibly RAID-6), which would tolerate the failure of 1 or more bricks. This enhancement would allow increased data integrity and increased usable storage as compared to current options (like replica 2).
Comment 1 Amar Tumballi 2012-11-02 03:18:45 EDT
Hello Dynamic Packet... 

Please have a look at http://www.gluster.org/community/documentation/index.php/Planning34/Disperse 

We will keep the current stripe translator as is, and will come up with new translator to handle the request you asked for.
Comment 3 Niels de Vos 2014-09-27 09:21:07 EDT
This is included in glusterfs-3.6 as disperse aka ec (erasure coding).

More details here:
- http://www.gluster.org/community/documentation/index.php/Features/disperse

*** This bug has been marked as a duplicate of bug 1118629 ***

Note You need to log in before you can comment on or make changes to this bug.