Bug 872012 - anaconda crashes if the thing returned when it tries to retrieve the .treeinfo file is not, in fact, a .treeinfo file
anaconda crashes if the thing returned when it tries to retrieve the .treeinf...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 21:08 EDT by Adam Williamson
Modified: 2012-12-20 11:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:23:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-10-31 21:08:14 EDT
This bug splits out the _original_ issue from https://bugzilla.redhat.com/show_bug.cgi?id=868558 , which we've turned into a report about the specific case of mirror list URLs.

The initial case in that bug seems to have been one where something funky happened in the selection of a mirror, and when anaconda's code to grab the .treeinfo file from the remote mirror fired, what anaconda wound up with was some random page from somewhere related to the server http://geoadserving.coffeetree.info/ . There is apparently no sanity check that what has been retrieved _actually is_ a .treeinfo file before anaconda tries to treat it as one - it just goes ahead and assumes that whatever it got was a .treeinfo file. When it does this to something that's not a .treeinfo file, it blows up prettily.

The question is exactly how to handle this better than crashing; pop up an error? What should the error say?

It's not a high priority issue because this should happen fairly rarely.
Comment 1 Fedora Update System 2012-11-07 22:34:19 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 2 Adam Williamson 2012-11-07 23:54:22 EST
for testing purposes, what should the fix for this do exactly? I can probably test it by faking up a repo with a bogus .treeinfo file.
Comment 3 Fedora Update System 2012-11-08 22:21:37 EST
Package anaconda-18.27-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.27-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.27-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-11-10 14:36:35 EST
Package anaconda-18.28-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.28-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-20 11:23:11 EST
anaconda-18.28-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.