Bug 872047 - fedup-dracut builds do not exist in F18
fedup-dracut builds do not exist in F18
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedup-dracut (Show other bugs)
18
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-01 01:08 EDT by Tim Flink
Modified: 2012-11-23 02:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:48:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2012-11-01 01:08:25 EDT
fedup-dracut is a required part of the upgrade process for F18 and forward.

At this time, there are no builds of fedup-dracut available in the F18 repositories.

Since this interferes with the ability to upgrade from F17 to F18, proposing as a blocker due to violation of the following F18 beta release criterion [1]:

For each one of the release-blocking package sets ('minimal', and the package sets for each one of the release-blocking desktops), it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using any officially recommended upgrade mechanisms. The upgraded system must meet all release criteria.

[1] http://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 1 Jaroslav Reznik 2012-11-01 12:21:31 EDT
Fedup F18 Bodhi update https://admin.fedoraproject.org/updates/fedup-dracut-0.7-1.fc18
Comment 2 Adam Williamson 2012-11-01 14:35:40 EDT
Discussed at 2012-11-01 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-01/f18beta-blocker-review-6.5.2012-11-01-17.49.log.txt . Accepted as a blocker per criterion cited in the description.
Comment 3 Nick Urbanik 2012-11-03 20:26:24 EDT
Is it still possible to yum upgrade a machine from F17?
Am I correct in saying that fedup-dracut is not required to achieve this?
Comment 4 Adam Williamson 2012-11-03 22:22:12 EDT
Yes and yes.
Comment 5 Fedora Update System 2012-11-21 21:01:41 EST
fedup-dracut-0.7.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-18721/fedup-dracut-0.7.1-1.fc18
Comment 6 Tim Flink 2012-11-22 13:16:50 EST
Since we have fedup-dracut builds in updates-testing now, moving to VERIFIED
Comment 7 Fedora Update System 2012-11-23 02:48:28 EST
fedup-dracut-0.7.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.